Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Error in Sapphire


Go to End


5 Posts   1359 Views

Avatar
fida

Community Member, 3 Posts

11 January 2011 at 11:34pm

Hello!

I recently downloaded SilverStripe and I'm trying to install it.
I simply pointed by web browser to silverstripe (http://localhost/silverstripe) and I got this error:

Fatal error: Class 'Session' not found in C:\wamp\www\silverstripe\sapphire\main.php on line 68

Please is there anyone that can help me!

Thanks!

Avatar
Willr

Forum Moderator, 5523 Posts

12 January 2011 at 8:30pm

Check to see the Session file exists. It should be sapphire/core/Session.php. Also try a ?flush=1 to ensure the latest files are being used.

Avatar
fida

Community Member, 3 Posts

12 January 2011 at 9:12pm

Hello!

Thanks for your reply.
The Sessions.php was not created.
How can I solve it?

Thanks for your help!!

Regards,
Fida

Avatar
Willr

Forum Moderator, 5523 Posts

12 January 2011 at 9:50pm

It should be in the download. Perhaps redownload it.

Avatar
fida

Community Member, 3 Posts

12 January 2011 at 9:55pm

thanks I will try that :)