Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

multiple errors in a row

Go to End

5 Posts   2170 Views


Community Member, 3 Posts

23 February 2011 at 4:48am

Edited: 24/02/2011 12:29am


I decided to try SS again (already tried it around 2 years ago, and now decided to give it another shot) but while trying to install it, i ran in error after error, let me elaborate:

the System:

$ mysql --version
mysql  Ver 14.14 Distrib 5.1.41, for debian-linux-gnu (x86_64) using readline 6.1

$ php --version
PHP 5.3.2-1ubuntu4.7 with Suhosin-Patch (cli) (built: Jan 12 2011 18:36:55) 
Copyright (c) 1997-2009 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies

Okay, i downloaded the current package (SilverStripe-v2.4.5) and unpacked it under a new local domain, when calling the install.php i got this message:

Fatal error: Class 'MySQLDatabaseConfigurationHelper' not found in /home/hannes/workspace/silverstripe/install.php on line 756

Just to humor myself i added

on line 57 in the install.php.

Which lead to the following, an working install screen that told me (attachment 1 SilverStripeCMSFrameworkInstallation_1298389363848.png)

That username/password doesn't work: Access denied for user 'root'@'localhost' (using password: NO)
Warning: Invalid argument supplied for foreach() in /home/hannes/workspace/silverstripe/sapphire/dev/install/config-form.html on line 95

without me ever entering any Database Information at any point, but anyhow, i added the Information manually in the install.php between line 106 and 115, after that the SS Msg was gone, the "Warning: Invalid argument supplied for foreach() in /home/hannes/workspace/silverstripe/sapphire/dev/install/config-form.html on line 95" remained.

In any case i could finally start the Installation, after it finished I got the error

Fatal error: Class 'Debug' not found in /home/hannes/workspace/silverstripe/sapphire/core/Core.php on line 252
when i tried to open the project - where i now throw the towel.


Heres a Backtrace from the Time when the first Error occurs:

#0  InstallRequirements->getDatabaseConfigurationHelper(MySQLDatabase) called at [/home/hannes/workspace/silverstripe/install.php:767]
#1  InstallRequirements->requireDatabaseFunctions(Array ([type] => MySQLDatabase,[server] => localhost,[username] => root,[password] => ,[database] => SS_mysite), Array ([0] => Database Configuration,[1] => Database support,[2] => Database support in PHP,[3] => MySQL)) called at [/home/hannes/workspace/silverstripe/install.php:227]
#2  InstallRequirements->checkDatabase(Array ([type] => MySQLDatabase,[server] => localhost,[username] => root,[password] => ,[database] => SS_mysite)) called at [/home/hannes/workspace/silverstripe/install.php:175]


same Result when installing over GIT & Nightly Build


Forum Moderator, 5523 Posts

23 February 2011 at 2:20pm

Do you have a MySQLDatabaseConfigurationHelper.php file (and is it readable)? Seems quite strange for it to not be included but then again I haven't used the installer in a while!

Make sure you're using 2.4 and not a checkout of trunk. Trunk will likely have some crazy bugs for the next few months while all the new features for 3.0 are thrown in!


Community Member, 3 Posts

23 February 2011 at 9:41pm

i used the latest regular download (SilverStripe-v2.4.5)

The file Exists and all files have an 755

~$ ls -lha workspace/silverstripe/sapphire/dev/install/MySQLDatabaseConfigurationHelper.php 
-rwxr-xr-x 1 hannes hannes 4.2K 2010-06-02 07:40 workspace/silverstripe/sapphire/dev/install/MySQLDatabaseConfigurationHelper.php


Community Member, 3 Posts

26 February 2011 at 2:15am

It has probably something to do with the autoloader ... but for the life of me I can't figure out what ( i can patch the installation to run, but always bump in to another error in the next step)


Forum Moderator, 5523 Posts

26 February 2011 at 12:20pm

Sorry to hear you're still having issues! Perhaps try not using the installer? All the installer handles is requirement checking the generates a mysite/_config.php + .htaccess file. You can download both from