Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Error on installtion - on "Building database schema..." some fopen() fails?

Go to End

4 Posts   1524 Views


Community Member, 3 Posts

22 May 2011 at 2:44am

Hi guys, I hope you are well.

I'm writing on this forum to, hopefully, get some help and I'm sorry if this question has been posted already.

I am receiving a weird error on installation (I've attached a screen grab of it) at the "Building database schema..." step. Some sort of warning, like if an fopen() function fails. Why is this happening? I have made all the changes to pass all the preliminary checks and, after setting permissions, php extensions, db name etc. all lights are green. Shouldn't the system spot a permission problem (or something similar) in advance??

Anyway, few elements to hopefully help troubleshoot this:

• If I do a chmod -R 777 on the whole SilverStripe folder it installs fine. So it's definitely a permissions issue, but where? :(

• If I try to install the same package on my MAMP installation (without doing any 777 chmod) all works absolutely fine.

• Finally some info about the server: FreeBSD 6.4-RELEASE-p8, PHP 5.2.17, MySQL Server version: 5.0.85.

I hope you guys can give me a hand because I liked SilverStripe very much when I tried it last year and I got back to it now that I have a new server. Of course, if it has basic problems, I may need to go back to some more reliable package.

Thank you very much in advance!

Attached Files

Community Member, 3 Posts

22 May 2011 at 3:35am

Hi guys,

I've of course solved the problem (stupid me!) and I'd like to post the solution I've found, just in case someone else is having the same issue.

Starting from the clue that everything worked fine if I changed permissions to 777 on all files and folders, I realized that the problem was the owner. I had the owner and group set to whatever was created after the unzipping, o: my user g: www. By setting the owner to www as wel, all the permissions problems disappeared. This was a bit confusing for me because usually most of the stuff I have on the server belongs to my user with group www and all works (Drupal, WordPress etc.). So this is why I didn't think of this as a possible culprit.

I hope this will help someone. Thanks for your attention.


Forum Moderator, 1391 Posts

23 May 2011 at 12:28am

Could be that (some of) the files in your assets folder came away as having only the correct read/write rights for the owner, so the webserver doesn't have sufficient rights. It shouldn't be necessary to change the owner to www I'd think...


Community Member, 3 Posts

23 May 2011 at 7:18am

Hi martimiz,

Thanks for your time. I'm sorry, but I'm not completely sure I understood your reply. If you meant that it's enough just for some of the files in the assets folder to have the right permissions for the www user, I am not sure how I would be supposed to know which ones? Besides the first installation screen was showing all green lights and that screen does permissions tests: in fact it asked me to change permissions at least on 3 files before allowing me to proceed with the installation.

In general I think this could be improved to be honest. As I told earlier, most of the other CMS I test, from commercial to free ones, work once I set the right permissions on the files / folders they ask me to set. The fact that the files belong to "my user / www" as "owner / group" (since I upload with an FTP client) is pretty much never an issue.

Hope this makes sense, but please let me know if you meant something different. Thanks.