Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

[SOLVED] Enabling mod_rewrite

Go to End

12 Posts   9297 Views


Forum Moderator, 267 Posts

10 January 2014 at 6:11pm

This issue relates to differences between apache 2.2 and the newer 2.4.

You'll need to add this to your httpd.conf file where you set the vhost directory:

AllowOverride All
DirectoryIndex disabled
Options MultiViews Indexes SymLinksIfOwnerMatch IncludesNoExec

I found the XAMPP and other stacks running 2.4 apache work fine after that and you can leave your indoex.php where it is (even tough technically you can remove it as htaccess does all the work there).


Hope that solves it for you.


Community Member, 3 Posts

10 January 2014 at 7:30pm

Edited: 10/01/2014 7:32pm

Awesome. That did it, thanks CamFindlay.

Coincidentally that is the second time you've helped me today. I enjoyed and commented on your talk on Silverstripe's Vimeo account today.

PS Looks like I've got two accounts on here. I'm Daniel B From the comment above.


Forum Moderator, 267 Posts

13 January 2014 at 2:34pm

No problem, I might look to add this into the WAMP documentation actually as the default versions of it are all running apache 2.4.

Also can you mark this thread as solved please. Just edit the first post in this thread and add [solved] to the start of the topic :)
Helps others with similar problem know where to look.


Community Member, 5 Posts

13 January 2014 at 7:54pm

Hi CamFindlay,

I agree I think this would be helpful for a few people. Sorry if you weren't talking to me but I did not start the thread so can't edit to solved. Anyway thanks again.

Go to Top