Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

No Errors

Go to End

3 Posts   717 Views


Community Member, 46 Posts

3 June 2012 at 11:12am

Hi All,
This is a new one for me. Using the latest stable download (2.4.7), I've installed silverstripe. Looking at the database, all tables are present, the members table exists with my email address in (as stated in the installation).

However, once installation is complete, I see the following:

"Installation Successful

Congratulations, SilverStripe has been successfully installed.

You can start editing your site's content by opening the CMS.

No email or password? When I try logging in with the specified username and password, no errors are displayed, but instead, I'm just shown the log in page once again. Does anyone have any ideas about this please?



Forum Moderator, 5523 Posts

3 June 2012 at 3:11pm

You can hard code an admin account by including the following in your _config.php file:

Security::setDefaultAdmin('admin', 'password');

Then that should at least give you access to the backend.


Community Member, 46 Posts

3 June 2012 at 9:19pm

Edited: 03/06/2012 9:33pm

Cheers Will, but this doesn't seem to change anything.

When you try to log in, it appears as if the page simply refreshes.


Edit: I've tried "I've lost my password", which successfully sends me an email, but when I click on the link, it asks me to log in.
I've also tried /dev/build?username=username&password=pass when it's in 'dev' mode, but this also seems to have no effect. The database appears to remain unchanged.


Edit (Again):
It seems to have been fixed. The domain name was a sub domain name (originally) "", just for development purposes. This was done due to an error of "/sapphire/main.php" not being found when run as "". However, by changing the .htaccess to state "RewriteBase /dev/", and run it from the /dev/ rather than the subdomain, this appears to have fixed it. (Hope that makes sense!)

Cheers for your help tho, just thought I'd post the outcome in case others go looking for a solution in the future.