Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

SilverStripe 3.0 Beta 3 issue : "tinyMCE is not defined"

Go to End

14 Posts   4005 Views


Community Member, 3 Posts

6 June 2012 at 8:10pm

I tried to make a fresh install the last beta 3 on two different servers (apache 2, php 5.3.13 [dotdeb], debian squeeze).
Same problem :
The content editor failed to appear.
Firebug sayd :

"tinyMCE is not defined"

more info in the attached screenshot.

Any idea ???

Attached Files

Community Member, 3 Posts

9 June 2012 at 2:41am


anyone ?


Forum Moderator, 1391 Posts

14 June 2012 at 4:23am

Hi f2sm,

It looks like you're using French as your profile language. I've noticed this happening in an earlier beta, using de_DE or nl_NL in my profile. It seemed to have something to do with missing JavaScript language files at the time.

Can you confirm this the issue still exists when you change your profile language to en_US?


Community Member, 3 Posts

14 June 2012 at 6:53pm

Thanx for your answer.

Unluckly, I tried and it did not work even with US langage...

but luckly, I just managed to understand my mistake.

The installation process page always stopped saying there was a problem with friendly urls, but without clear failure message I just believed it was a small warning.... but I just added "AllowOverride All" to my apache configuration file and that's it ! And now I understand that the full installation process page is redirecting to the CMS frontpage.

What is missing there is a clear message saying that the installation FAILED because of the friendly url FAILURE. Because there was no clear message, I was always trying the CMS url and it seems OK... except the TinyMCE error.

My two cents : Do not enable the frontpage until the installation is fully successful and/or make a more clear FAILURE message about the friendly urls checking step.

Thanx for all your work and answers.


Community Member, 1 Post

8 July 2012 at 3:38am

Edited: 08/07/2012 11:48am

Hello f2sm.

Can you explain the changes you made to ".htaccess"?
I have the same problem you posted within your screenshot.

My provider is 1&1 and i just upgraded to "1&1 DUAL ADVANCED" to get SS3 running.
SilverStripe comes from stable download 3.0.0/28. June

It also seems that Javascript not working properly. Links in nav and tree are not always working, after clicking nothing happens.

Thanks in advance


Community Member, 5 Posts

14 August 2012 at 1:22am

I am facing the same error with the 3.0.1 stable version.
I am using en_us

There were no errors while installation.

Is there any solution for this ?


Community Member, 7 Posts

27 August 2012 at 10:32am

I am also having the same problem with 3.0.1

Is anyone working on this problem? A solution is urgently needed.


Community Member, 3 Posts

28 August 2012 at 9:35pm

@f2sm I cannot stress enough how much I agree!
I almost gave up on SilverStripe because of this. When installing at first, it appears that the AllowOverride All is a MINOR warning. Which it clearly is not. Please add a beautiful blood red message clarifying that the thing FAILED.
Otherwise, this thing looks good. Thanks for all the work.

Go to Top