Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

SilverStripe 3.0 Beta 3 issue : "tinyMCE is not defined"

Go to End

14 Posts   4004 Views


Community Member, 473 Posts

30 August 2012 at 10:18am

I just pushed a fix for this that'll be included in 3.0.2. In the mean time, you can grab the updated index.php file from


Community Member, 7 Posts

30 August 2012 at 11:12am

Simon's index.php update seems to solve the tinymce problem.

Before discovering this, I solved the problem by going to the HtmlEditorField class (in farmework/forms) and turning off using gzip.
Simply change $use_gzip on line 14 from true to false.


Community Member, 3 Posts

30 August 2012 at 7:07pm

Thanks Simon. Will give it a try. Cheers


Community Member, 5 Posts

30 August 2012 at 8:18pm

Did you manage to resolve the issue ?
Even I am facing the same issue. What is the solution for this ?


Community Member, 3 Posts

30 August 2012 at 9:54pm

I haven't tried the Simon's patch yet, hands are full today.
You have to make sure that the installation script finishes cleanly (normally redirecting you to your new installation).
If it ends warning that it cannot use clean urls then you need to make sure that the directives on your Apache is configured with the mod rewrite module enabled and that the <Directory> directive in the appropriate web server configuration file (httpd.conf -or vhosts.conf if you are using that) allow overrides. Here's my setup:
<Directory "/Library/WebServer/Documents/silverstripe">
Options Indexes FollowSymLinks MultiViews
AllowOverride All
Order allow,deny
Allow from all
(note that this is a dev setup and bit permissive. It might not be safe for production, depending on your needs)
Hope it helps.


Community Member, 5 Posts

31 August 2012 at 10:39pm


Thanks Simon for the fix. It works!!

Go to Top