Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

installing silverstripe 3.0 error

Go to End

25 Posts   12957 Views


Community Member, 224 Posts

1 July 2012 at 4:24pm

I need some help getting 3.0 installed on a shared server.

everything is cleared on the install.php page, but when I click the Install Silverstripe button, I get this error...

Warning: require_once(zend_translate_railsyaml/library/Translate/Adapter/RailsYAML.php) [function.require-once]: failed to open stream: No such file or directory in /home/aliyswor/public_html/framework/i18n/i18nRailsYamlAdapter.php on line 3

Fatal error: require_once() [function.require]: Failed opening required 'zend_translate_railsyaml/library/Translate/Adapter/RailsYAML.php' (include_path='/home/aliyswor/public_html/framework:/home/aliyswor/public_html/framework/parsers:/home/aliyswor/public_html/framework/thirdparty:.:/usr/lib/php') in /home/aliyswor/public_html/framework/i18n/i18nRailsYamlAdapter.php on line 3

Seems the zend... is missing - please help!
Thank you,

Attached Files

Community Member, 224 Posts

1 July 2012 at 6:15pm

These are the files the require_once is looking for

require_once 'Zend/Translate.php';

require_once 'zend_translate_railsyaml/library/Translate/Adapter/RailsYAML.php';

This folder or files do not exist in the SS 3.0 install


Community Member, 2 Posts

1 July 2012 at 11:10pm

Edited: 02/07/2012 9:29pm

Same error here (SS-3 installation in subfolder »silver«) on shared server; installation works local with MAMP:

Setting up 'mysite/_config.php'...
Setting up /var/www/virtual/knud/html/silver/mysite/_config.php
Building database schema...
Warning: require_once(zend_translate_railsyaml/library/Translate/Adapter/RailsYAML.php): failed to open stream: No such file or directory in /var/www/virtual/xxxxx/html/silver/framework/i18n/i18nRailsYamlAdapter.php on line 3 Fatal error: require_once(): Failed opening required 'zend_translate_railsyaml/library/Translate/Adapter/RailsYAML.php' (include_path='/var/www/virtual/xxxxx/html/silver/framework:/var/www/virtual/xxxxx/html/ silver/framework/parsers:/var/www/virtual/xxxxx/html/silver/framework/thirdparty:.
:/package/host/localhost/php-5.3.10-3/lib/php') in /var/www/virtual/xxxxx/html/silver/framework/i18n/i18nRailsYamlAdapter.php on line 3


Community Member, 1 Post

6 July 2012 at 11:19pm

I had the same error, it seemed that the files which silverstripe was looking for were there, but with a .ph extension instead of the php extension. So if you locate all files in: ..\framework\thirdparty\zend_translate_railsyaml\library\Translate and it subfolders and change the extension the installation should work again!


Community Member, 2 Posts

7 July 2012 at 11:10pm

Edited: 07/07/2012 11:10pm

Hello Karin, thats it! Al file suffixes in
are corrupted. After correcting them installer is working.
Thank you!


Community Member, 72 Posts

10 September 2012 at 6:34am

This error is still occurring with the latest download of SS 3.0.1 !! Would someone from the dev team please rename these files to the correct extension otherwise it's going to put people off upgrading or using Silverstripe 3.0.1....


Forum Moderator, 922 Posts

26 September 2012 at 9:55am

Edited: 26/09/2012 9:55am

Hi everyone,

We're looking into this.

It's a bit strange, because using "tar -xzf SilverStripe-cms-v3.0.2.tar.gz" doesn't produce the problems with broken extensions on my Ubuntu 11.04 server.

Could affected people please let me which OS and version they are installing SilverStripe on, and how they extracted the files and uploaded them to their servers, including software used to do so, e.g. 7zip.

My initial thoughts are that we're hitting some filesystem limit, as the path can get extremely long for the thirdparty files.



Community Member, 470 Posts

26 September 2012 at 11:41am

Using os x 10.8.2

Downloaded from the download page, extracted on my Mac with the unarchiver. Zipped up framework/cms and uploaded those to the server.

Go to Top