Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

installing silverstripe 3.0 error

Go to End

25 Posts   12908 Views


Community Member, 67 Posts

8 October 2012 at 5:38pm

I have tested this on a Mac running 10.7.4 using the default Archive Utility and The Unarchiver and it has worked for me.

I suspect it may be to do with how the metadata is being handled so I have run the mdls command from terminal on the files to view the metadata which I have attached it would be interesting to see if the results from another machine experiencing problems has different metadata info.

Attached Files

Community Member, 25 Posts

11 October 2012 at 5:28am

Sorry for the misinformation. My Unarchivers have somehow started cooperating somewhere along the way. But definately remember having troubles in the time 3.0 betas where released.


Community Member, 15 Posts

11 October 2012 at 3:19pm

Edited: 11/10/2012 5:04pm

I am having problems as well with this - it is proving stupidly annoying to try and just get Hello World running on SilverStripe 3.0.2.

So my setup

Windows 7 32bit

I had to manually change files with extension .ph to .php

After address that issue I get the following error after installation:

Friendly URLs are not working. This is most likely because a rewrite module isn't configured correctly on your site. You may need to get your web host or server administrator to do this for you:

mod_rewrite or other rewrite module is enabled on your web server
AllowOverride All is set for the directory where SilverStripe is installed

I tried many things to get rid of this error and then just ignored it...

If I try and go to the site itself I get the following:

Fatal error: Maximum execution time of 30 seconds exceeded in C:\wamp\www\silverstripe\framework\thirdparty\Zend\Cache\Backend\File.php on line 957
Call Stack
# Time Memory Function Location
1 0.0027 159464 {main}( ) ..\main.php:0
2 0.0067 235264 require_once( 'C:\wamp\www\silverstripe\framework\core\Core.php' ) ..\main.php:62
3 0.0799 1084848 SS_ClassManifest->__construct( ) ..\Core.php:268
4 0.1028 1377576 SS_ClassManifest->regenerate( ) ..\ClassManifest.php:133
5 0.1031 1382216 SS_FileFinder->find( ) ..\ClassManifest.php:284
6 29.0588 1678344 call_user_func ( ) ..\FileFinder.php:158
7 29.0588 1678368 SS_ClassManifest->handleFile( ) ..\FileFinder.php:158
8 29.0653 1759800 Zend_Cache_Core->save( ) ..\ClassManifest.php:346
9 29.0654 1760296 Zend_Cache_Core->clean( ) ..\Core.php:375
10 29.0654 1760376 Zend_Cache_Backend_File->clean( ) ..\Core.php:464
11 29.0655 1760304 Zend_Cache_Backend_File->_clean( ) ..\File.php:289
12 30.0098 1939312 Zend_Cache_Backend_File->_getMetadatas( ) ..\File.php:664
13 30.0098 1939312 Zend_Cache_Backend_File->_loadMetadatas( ) ..\File.php:480
14 30.0099 1939520 Zend_Cache_Backend_File->_fileGetContents( ) ..\File.php:547

Refresh that a few times and eventually I get to the CMS and it appears to be working...

But the truth is I have lost a little faith in the product already! Maybe I was being to clever by half actually trying to get rid of what look like serious errors but hey, it should be painless to get Hello World running.

Chris Mein


Forum Moderator, 922 Posts

11 October 2012 at 4:23pm

Edited: 11/10/2012 4:31pm

Hi Chris,

Sorry to hear you're having problems there.

We are having troubles with .tar.gz downloads with some users environments, we're still trying to find out why that happens. There is an alternative zip download for SilverStripe 3.0.2 here: which should work in the meantime.

The mod_rewrite issue could be resolved by checking and fixing the following:

mod_rewrite module for Apache is loaded. From my memory, there is a setting in the GUI for it in the WAMPServer system tray, alternatively, uncomment "LoadModule rewrite_module modules/" in the Apache configuration file by removing the # before it.

AllowOverride All set in the Apache configuration. Search for "AllowOverride none" and replace those with "AllowOverride All".

The Apache configuration is typically found in apache/conf/httpd.conf, wherever WAMPServer is installed. Once you've made changes to the configuration file, you'll need to restart WAMPServer for the changes to make effect.

The next thing to try is using for the MySQL server username in the SilverStripe installer, instead of "localhost". There are sometimes issues where using localhost takes much longer to connect to the database on Windows. Although I don't know if that's fixed in later versions, but worth a try.

Let me know how you get on.



Community Member, 25 Posts

11 October 2012 at 11:57pm

Edited: 11/10/2012 11:58pm

Spoke too soon. The osx built in archiver utility seems to be working but "The Unarchaiver" does not.

First it asks about encoding which I leave at preselected Western ASCII.

And the result

Added my mdls of the gz archiver if that gives any insight

Attached Files

Community Member, 15 Posts

13 October 2012 at 11:07am

Edited: 15/10/2012 1:25pm


I will try the instructions for WAMP as soon as I get back to the office on Monday.

In the meantime I am trying this with LAMP on Ubuntu 12.04 running on a free tier Amazon AWS instance. Same issue (along with a few other problems) that weren't so odd.

It seems to me that if you are completely new to PHP/SilverStripe then you are going to get these issues everytime because you simply won't have installed this stack before. It would be so much (so so so much) easier if the install guides specifically addressed this problem before the 'Install SilverStripe' button was hit.

The problem I think occurs when you don't install SilverStripe in the base of /www (as the WAMP instructions suggest and I happened to do in LAMP as I wanted to do other things with Apache as well). So a simple warning about that perhaps on the install.php screen would be a big help.

Thanks for the help


PS I am now up and running on both WAMP and LAMP, starting from fresh on both environments. Thanks


Community Member, 67 Posts

8 November 2012 at 4:34pm

Edited: 08/11/2012 4:35pm

Would be interested to know if anyone is still experiencing problems with the tar.gz file.

I checked the original folder created from the gzip file I downloaded from and it contained a .DS_Store file but I am not certain if it was created after expanding the file.

SilverStripe 3.0.3 is currently available as a release candidate so the 3.0.3 is not too far away a new gzip and zip file will be generated for that so hopefully we will not experience the same issues with them.


Community Member, 15 Posts

6 December 2012 at 1:16pm


The problem behind this bug has been traced to an issue with the .tar.gz package and the use of WinZip on Windows (and maybe some other zip tools).

I commented on this post and eventually had other issues that are described here -

Everything works fine now though simply by using 7Zip or the new .zip archive as described here -

So don't be put off, SilverStripe 3 is very nice to use