Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Silverstripe allocating 71 MB of memory

Go to End

5 Posts   2150 Views


Community Member, 9 Posts

26 July 2012 at 11:47pm

Edited: 27/07/2012 3:56am


I'm trying to install silverstripe 3.0 on my webserver. It is a shared webhosting webserver, that meets all the requirements. It runs php 5.3.2 and MySql 5.
It also meets the set requirements for memory allocation. I checked this via the phpinfo() and it is set to 64 MB, while 48 MB is required.

However when I try to install silverstripe, it tells me that a fatal error occurs cause it tries to allocate 71 MB of memory. Is this a glitch/bug in the software somewhere, did I configure something wrong?

Any thoughts would be appriciated.

Jan Jaap

Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 72 bytes) in /home/vhosting/i/vhost0049995/domains/ on line 27


Forum Moderator, 5523 Posts

28 July 2012 at 1:39pm

SilverStripe often requires more than 64mb. I run my sites with 128mb but it depends on what you're using SilverStripe for (lots of pages, images, loading files) all uses more memory. You could use a tool like xhprof to investigate your memory usage. On a plain 3.0 checkout on my machine, it uses 32mb of RAM. Once you add pages, more classes that will go up.


Community Member, 126 Posts

4 September 2012 at 9:03am

Edited: 04/09/2012 9:04am

i don't think it has to do with "lots of pages, images, loading files" or anything else, as DubbeleJ mentions "when i try to install silverstripe..." which sounds like a plain install.

in fact, i'm having exactly the same problem on some shared host (, using a plain 3.0.1 install. must be something trickier.
@DubbeleJ did you make any progress on the issue?


Community Member, 267 Posts

12 September 2012 at 8:29pm

Im having the same problem:

Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 71 bytes) in /public/sites/URL/framework/core/manifest/TokenisedRegularExpression.php on line 23

cant upgrade my memory on my shared hosting..


Community Member, 126 Posts

13 September 2012 at 7:05pm

i had to upgrade my hosting package so it would support 80M of php memory - then everything was working just fine. guess there's no easy way to get around this extensive memory consumption...