Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

"Is the temporary directory writeable?" on SS3 install

Go to End

3 Posts   982 Views


Community Member, 3 Posts

27 November 2012 at 6:22am

Unfortunately whilst trying to install SS3 on shared hosting I'm getting the "Is the temporary directory writeable?" error.

I know this is a frequently asked question and that it should be an easy error to fix, but the solutions posted in these forums haven't worked in my case. I've tried creating 'silverstripe-cache' with 777 permissions in the following places:
/public_html/ (where cms, framework, etc. is located)

I'm struggling to understand why SS3 isn't finding this folder after realising that it doesn't have sufficient permissions to write to it on shared hosting. I've even tried changing the getTempFolder method in framework/core/Core.php.

I've had a lengthy conversation with technical support at Zen Hosting and the only solution they could come up with is to enquire on these forums.

Thanks in advance.


Administrator, 25 Posts

4 December 2012 at 2:50pm

Hi Matthew,

Try CHOWN to www-data (assuming you're running a Linux environment). Let me know if that helps.


Community Member, 3 Posts

7 December 2012 at 7:52am

Hi Van, thanks for your reply.

Yes I'm in a Linux environment. How do I go about changing the ownership of a file? ftp doesn't have chown and I'm not sure how to ssh into the server. I've tried ssh and ssh Furthermore, the control panel they have installed (cPanel) doesn't provide an equivalent functionality. Thanks again.