Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

SS3 friendly Urls -> Provider 1und1.de


Go to End


2 Posts   1263 Views

Avatar
dh_berger

Community Member, 1 Post

16 March 2013 at 3:06am

hi,
Ich have a problem with the friendly urls on my domain.
currently is it:

http://stage.XXXX.de/index.php/contact-us/

but i need:

http://stage.XXXX.de/contact-us/

.htacces:

### SILVERSTRIPE START ###
<Files *.ss>
Order deny,allow
Deny from all
Allow from 127.0.0.1
</Files>

<Files web.config>
Order deny,allow
Deny from all
</Files>

ErrorDocument 404 /assets/error-404.html
ErrorDocument 500 /assets/error-500.html

<IfModule mod_alias.c>
RedirectMatch 403 /silverstripe-cache(/|$)
RedirectMatch 403 /vendor(/|$)
RedirectMatch 403 /composer\.(json|lock)
</IfModule>

<IfModule mod_rewrite.c>
SetEnv HTTP_MOD_REWRITE On

AddType x-mapp-php6 .php
AddHandler x-mapp-php6 .php

RewriteBase /

RewriteCond %{REQUEST_URI} ^(.*)$
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_URI} !\.php$
RewriteRule .* framework/*.php?url=%1 [QSA]

RewriteCond %{REQUEST_URI} ^(.*)/framework/main.php$
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule . %1/install.php? [R,L]

</IfModule>
### SILVERSTRIPE END ###

php.ini:

memory_limit = 100M;
upload_max_filesize = 40M;
max_execution_time = 50000;
max_input_vars = 5000;
safe_mode = Off;
magic_quotes_gpc = Off;
date.timezone = "Europe/Berlin";
mysql.default_socket = /tmp/mysql5.sock;
mysqli.default_socket = /tmp/mysql5.sock;

Can you help me?

best regards
dh_berger

Avatar
Bambii7

Community Member, 254 Posts

3 May 2013 at 5:42pm

Hallo dh_berger
I know this is an old post but in case you're still having issues with this.
First thing make sure it's not .htacces but .htaccess I guess thats probably a typo.
Secondly your apache install needs to have mod_rewrite enabled.

To enable it you'll need root access to the server in order to run this is a terminal
a2enmod rewrite
service apache2 restart