Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Composer install failure


Go to End


2 Posts   1366 Views

Avatar
prezet

Community Member, 6 Posts

20 September 2013 at 7:48am

I'm trying to install SS via composer... so I run the following:

composer create-project silverstripe/installer ./silverstripe 3.0.5

Which seems to run fine apart from getting the following message:

'[RuntimeException] The lock file does not contain require-dev information, run install with the --no-dev option or run update to install those packages.'

so next I run:

cd silverstripe && composer install --no-dev

To which I receive:

'[Composer\Downloader\TransportException] The "https://api.github.com/repos/silverstripe/sapphire/zipball/3.0.5" file could not be downloaded (HTTP/1.1 404 Not Found) '

What am I doing wrong?

Avatar
Sean

Forum Moderator, 922 Posts

20 September 2013 at 11:37am

Edited: 20/09/2013 11:37am

Sometimes the links on Github break. In that case you can have it download the sources via Git:

composer install --no-dev --prefer-source

Hope that helps.

Sean