Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Admin Links Broken

Go to End

3 Posts   935 Views


Community Member, 2 Posts

18 October 2013 at 1:27am

Edited: 18/10/2013 1:29am


I've just done a fresh install of SliverStripe in my hosted web space. I did initially get errors in the install, but after renaming the .ph files to .php (as per a forum post) the install completed successfully.

The problem I have now is that when I log into the admin page, none of the links in the admin menu work. Nothing happens when I click on them. If I manually type the path for that option it works OK. Also, when clicking on the entries in the Pages tab, nothing happens. I can see the link that it should go to appear at the bottom of the Chrome page so I know it should be doing something.

Also, when I manually go to one of the admin pages and make a change then click Save, the saving animation just continues to spin and it doesn't seem to commit the changes.

I have tried changing the permission for all the files on the site to 755 as suggested, and I have tried the site from different machines with different browsers.

Any ideas how I fix this issue so I can start to build my site.

Thanks for your help!

Cheers, Keith.


Community Member, 254 Posts

18 October 2013 at 3:27pm

Hi Keith,
Are you able to check your php error logs? Should give a good hint to the issue.

How did you get the SS files? Composer/Git/Zip?
I only ask because I had issues downloading a tar.bz2 or something and extracting through a terminal. Basically I wasn't extracting the files correctly and ended up with some truncated file names like .ph

There may be other files besides php files affected, it might have messed up some js files also. For that reason you could also check the console log in your browser.


Community Member, 2 Posts

19 October 2013 at 1:40am


Thanks for your reply!

I had just clicked on the Download button on the download page, extracted the contents and then uploaded it to my web space.

After reading your reply, I went back and checked and true enough it was the tar.gz file which I had downloaded. I clicked the link below for the Windows .zip file and went through the same procedure, and it is now working perfectly.

Thanks for your time and assistance!

Cheers, Keith.