Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

File Permissions 3 Failed and 0 Warnings

Go to End

3 Posts   1913 Views


Community Member, 2 Posts

8 December 2013 at 5:43pm

Hello all,

I am new to SS and have been trying to install SS 3.1.2 on CentOS 6.5. I have tried Composer and direct installation but both end-up with the same set of errors. Everything goes fine until I connect to that takes me to install.php where I get below errors:

The webserver user needs to be able to write to this file:
The webserver user needs to be able to write to this file:
The webserver user needs to be able to write to this file:

I have followed the instructions and setup the correct owner as:
#chown -R apache:apache /var/www/html/silverstripe

And also set the correct permissions as:
#chmod 755 -R /var/www/html/silverstripe/assets
#chmod 755 /var/www/html/silverstripe/./htaccess
#chmod 755 /var/www/html/silverstripe/mysite/_config.php

After spending almost 2 days non-stop on this I am unable to install SS on my server. I am not sure what else to do? I've read almost every web post related to the issue and tried to follow solutions but nothing seems to fix it.

Any help with the resolution is appreciated in advance.


Attached Files

Forum Moderator, 922 Posts

17 December 2013 at 10:01am


Is SELinux enabled? That could what's causing the permission problems, even though you've set the group and write permissions correctly.



Community Member, 2 Posts

19 December 2013 at 4:48am

Hi Sean,

You are correct, I guess the SELinux was the issue. I gave up on the Composer install and went ahead with the individual install on a brand new VM and it worked. I was able to setup the CMS and update sample website as a generic user under /home/testuser/public_html/silverstripe directory and the site worked fine. However, I couldn't set up a site under /var/www/html/silverstripe directory. Any thoughts?