Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Fatal Error on Install :-(


Go to End


3 Posts   1878 Views

Avatar
dbweb

Community Member, 1 Post

19 December 2008 at 1:47am

Hi all

Trying to install SS on Media Temple.

Fatal error result

I am now running through the installation steps (this should take about 30 seconds)

If you receive a fatal error, refresh this page to continue the installation
# Creating 'mysite/_config.php'...
# Creating /nfs/c01/h03/mnt/954/domains/dbrazil.com/html/silver_stripe/mysite/_config.php
# Creating '.htaccess' file...
# Creating /nfs/c01/h03/mnt/954/domains/dbrazil.com/html/silver_stripe/.htaccess
# Building database schema...

Notice: Warning: there are two 'Extension' files with the same filename: 'serverpath/html/silver_stripe/sapphire/core/Extension.php' and 'serverpath/html/silver_stripe/auth_openid/code/Auth/OpenID/Extension.php'. This might mean that the wrong code is being used. in serverpath/html/silver_stripe/sapphire/core/ManifestBuilder.php on line 256

Notice: Warning: there are two 'XML' files with the same filename: serverpath/html/silver_stripe/sapphire/integration/XML.php' and 'serverpath/html/silver_stripe/auth_openid/code/Auth/Yadis/XML.php'. This might mean that the wrong code is being used. in serverpath/html/silver_stripe/sapphire/core/ManifestBuilder.php on line 256

Fatal error: Class 'Extension' not found in serverpath/html/silver_stripe/sapphire/core/model/DataObjectDecorator.php on line 16

Any assistance would be greatly appreciated.

Using current stable release downloaded today

Thanks

Avatar
Nivanka

Community Member, 400 Posts

22 December 2008 at 3:04am

hi,

make sure that you that your silverstripe directory is in 777 state.

Avatar
Hamish

Community Member, 712 Posts

22 December 2008 at 8:36am

Also, if you don't need openID authentication, remove the entire auth_openid folder.