Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Can't install Silverstripe (syntax error)


Go to End


6 Posts   3061 Views

Avatar
samadeus

Community Member, 27 Posts

21 December 2008 at 8:05am

Hello

I have uploaded the installation folder to my OVH hosting account, then i went to install file, but each time i get this error:

Parse error: syntax error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in /homez.65/ikgbcldw/www/silverstripe-v2.2.3/install.php on line 518

http://300gp.ovh.net/~ikgbcldw/silverstripe-v2.2.3/install.php

Should i give special right to this file?

Any help is muh appreiated!

Avatar
(deleted)

Community Member, 473 Posts

21 December 2008 at 8:46am

This is because you're running PHP4. SilverStripe requires PHP5.

Avatar
samadeus

Community Member, 27 Posts

21 December 2008 at 10:14am

Hello Simon

I asked OVH and they told me that they support both 4 and 5

It could be somthing alse then?

Avatar
Hamish

Community Member, 712 Posts

21 December 2008 at 8:47pm

No. They have you set up with PHP4. Ask them to upgrade you to 5.

Avatar
samadeus

Community Member, 27 Posts

25 December 2008 at 4:05am

Thanks a lot!

I did as described here to switch to PHP5 and it works great
http://help.ovh.co.uk/Php5AtOvh

Avatar
Sigurd

Forum Moderator, 628 Posts

8 January 2009 at 1:13pm

Edited: 08/01/2009 1:13pm

Cheers Hamish, simon_w for helping out :)