Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

INstall does not like a minus (-) in Database name?!

Go to End

12 Posts   5476 Views


Community Member, 9 Posts

1 January 2009 at 11:08am

I have a strange effect here:

From my hoster it's set fast that the databases all have a - in their name.
But when I enter the name with a minus in the name into the installier field for the database name, as soon as I exit the text field, the minus is removed, and I clearly get errors that my user cannot acces the datbase... no wonder as the database name is wrong like that!

I cannot install silverstripe on my hoster like that.


Community Member, 9 Posts

1 January 2009 at 11:17am

BTW: I tried to turn off JavaScript, then the install pages shows "green light" that everything is O.K. for installation("These database details look all good! "), but when running install, I still get:

Installing SilverStripe...

I am now running through the installation steps (this should take about 30 seconds)

If you receive a fatal error, refresh this page to continue the installation
# Creating 'mysite/_config.php'...
# Creating /is/htdocs/wp1091032_YZWO3J4ZKV/www/silverstripe-test/mysite/_config.php
# Creating '.htaccess' file...
# Creating /is/htdocs/wp1091032_YZWO3J4ZKV/www/silverstripe-test/.htaccess
# Building database schema...

Warning: $project isn't set in /is/htdocs/wp1091032_YZWO3J4ZKV/www/silverstripe-test/sapphire/core/ManifestBuilder.php on line 154

Fatal error: DB::connect: Not passed a valid database config in /is/htdocs/wp1091032_YZWO3J4ZKV/www/silverstripe-test/sapphire/core/model/DB.php on line 53

I checked the setting again and again, a bunch of other apps are running well with it.
It seems definetely thta silverstream cannot work with databases with a minus in the name... can somebody confirm, or tell me wht else cvould be wrong?


Community Member, 1 Post

4 January 2009 at 7:28am

Hi Henning,

thanks for your post. I have excatly the same problem. Did you find any workaround jet?

In case you would like to talk to me, please feel free to get back to me at!



Community Member, 9 Posts

4 January 2009 at 12:34pm

Sort of - as it was an evaluation process for getting a well-working, easy to use CMS FAST, I decided toi install drupal and I'm quite happy with it :)

I'll get back at SilverStripe if it's a bit more mature... but usually I'm more a Java guy, ,so it's more likely I use things like grails and liferay later.


Forum Moderator, 628 Posts

6 January 2009 at 9:25am

Edited: 06/01/2009 9:53am

Henning, this is a known issue mentioned at that will be investigated in the future:

See my most recent comment - if you
a) first manually create the database,
b) edit the installer to allow hyphens (see URL above)
c) use the database given, and the install will work.

This will likely be fixed in an soon release.


Forum Moderator, 628 Posts

6 January 2009 at 9:29am

Just for the sake of curiosity, why is that you need hyphens? Does your host force all databases in the format "youraccount-somedb", like "henning-silverstripesite" or something?


Administrator, 690 Posts

6 January 2009 at 9:59am

This bug has been fixed and will be released in the next RC of 2.3.0.


Community Member, 9 Posts

6 January 2009 at 11:37am

Thanks for the info.

I'll check Silverstripe again when this new release(candidate)is available!
It might be a good match for customer websites where a better workflow and preview/staging is needed than drupal is - as far as I see in the demo, Silverstripe is better in that area.

As of the question why I need it: yes, my host provider ( has exactly the naming scheme you mention.
I could have tried it on a testing machine at home, but I would not want to test something that would not be usable on my webhost.

hmm, yes, I could have copied the database... anyway, I didn't come up with a better idea than jumping to drupal and as a personal publishing system for a one person company website, I like it so far ;)

Go to Top