Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

site defaults to page not found via check-php

Go to End

10 Posts   6331 Views


Community Member, 12 Posts

2 January 2009 at 3:34pm

Edited: 02/01/2009 6:24pm

Hi, Silverstrip looks great and has installed fine but when I access the site it defaults to the page not found page via

I though/think i have deleted the install files but..... duh maybe not?
What am i missing. i cannot see check-php anywhere! after deleting the page that it was defaulting to on load I get: [The requested page couldn't be found.] however, if I go to of my site .com/index/ manually it all looks fine. Very wierd.

Obviously something .... an index file is pointing to the (now missing) page on first load but i cannot find where this is!


Community Member, 5 Posts

2 January 2009 at 5:56pm

Look like your problem is the same as mine:


Community Member, 12 Posts

2 January 2009 at 5:58pm

Yes I think so. i just can't figure out why. I have checked everything that I can think of and flushed (and washed my hands)....:-)


Community Member, 25 Posts

3 January 2009 at 1:57am

Edited: 03/01/2009 1:58am

Have you added the domain ( to the "Use this page as the 'home page' for the following domains: (separate multiple domains with commas)"-field in the Behavior tab?
I think I had about the same behavoiur before, when I deleted the default home page and not added the domain to this field.


Community Member, 12 Posts

7 January 2009 at 12:29pm

You know that might be in Tobbe, thank you ... but there are two more steps required to make it work I think. 1. Flush (append /db/build?flush=1 to the end of your URL) and 2. Reset (flush) cookies in your broswer (I reset Safari)..... then all seems normal.

Thank you for the tip. :-)


Community Member, 470 Posts

8 January 2009 at 10:28am

Ya it's a caching issue. I've found just restarting the browser does the trick.


Forum Moderator, 628 Posts

8 January 2009 at 1:03pm

This is mentioned at this (now fixed) bug report -

Can you let us know if SS 2.3rc2 no longer contains this fault? :)


Community Member, 12 Posts

8 January 2009 at 1:27pm

Actually I was using SS 2.2.3 which i thought was the latest stable release as i only downloaded it a few days ago. Using that release on three simple sites i did experience the issue but was able to resolve it via the above process. i suspect it has as much to do with Safari cahing as anything else .... it was only after posting that i tried flushing/resetting Safari and have not tried *only* resetting without dong the other things..... so that makes my conclusion inconclusive if you know what i mean. :-)

PS. Thanks to the SS team for a really great CMS i am so happy with it! Discovering SS was a great start to 2009!

Go to Top