Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

While Installing: Parse error in OpenID.php

Go to End

2 Posts   1448 Views


Community Member, 1 Post

7 January 2009 at 6:36pm

Edited: 07/01/2009 6:38pm

I was trying to install SilverStripe on my webserver, but I can't get it to run through. I get as far as the installation "screen" in the browser. I enter my database information, details for the admin etc., and click on "Install SilverStripe". Then a new page is loaded, which ends in this (I substituted my real directory name with "xy"):

Installing SilverStripe...

I am now running through the installation steps (this should take about 30 seconds)

If you receive a fatal error, refresh this page to continue the installation

Creating 'mysite/_config.php'...
Creating /home/xy/mysite/_config.php
Creating '.htaccess' file...
Creating /home/xy/.htaccess
Building database schema...

Parse error: syntax error, unexpected T_STRING in /home/xy/auth_openid/code/Auth/OpenID.php on line 182

Except for the "Check that the php.ini setting allow_call_time_pass_reference is on" there were no warnings on the first page. I tried it again with the option turned on in my php.ini, but it's the same result (except that the error is not displayed anymore and the page just stops).

The text suggests that I should just reload the page. When I do that, I only get the error, and nothing else.

Any idea what's causing this? I looked at the file (OpenID.php) itself, but it looks OK. Can't really see any reason why it shows a parse error there. I also double checked the values I entered into the form on the first page, but it doesn't matter really what I enter - it always ends in this error.

The PHP version is 5.2.6.

Thanks in advance for any help!


Forum Moderator, 628 Posts

8 January 2009 at 1:05pm


Well, you can safely remove the auth_openid in the root folder completely if you can not figure the issue out ... (and of course have no open id support).