Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

First Install on new server.... ***solved***

Go to End



Community Member, 1 Post

7 February 2009 at 1:42pm

Edited: 07/02/2009 3:09pm

... Not a complete newbie but I've been away from php/linux for a while so I could be doing it all wrong but I don't think so...

***obvious mistake number 1 claiming any credibility. Safe mode was the clear culprit here, been away too long....***

Centos5 with apache 2.2 php 5.1.6

Tried both the stable and the svn builds. Both seem to have an issue with file permissions/ownership on this platform. First neither would write a _config.php in a mysite dir owned by apache and openly permissive (777), or with a precreated _config.php with similar attributes. Hacked install.php to create the config in the install dir and that worked (getting a feeling something here doesn't like creating files in directories) using the svn build. Moved the hack created config to the mysite dir. Then the install baulks with cache files in /tmp/, manages to create a directory but not a file (manifest-main). That no liking creating files in directories odd feeling is getting stronger... I'm guessing a php version or config issue, anyone care to point me straight?
Nice looking CMS by the way, you may have struck my desired perfect balance, just need to get past this little hurdle to confirm my suspicions...

Forgive any previous post blindness on my part should I be exhibiting symptoms...