Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Installation problem, stuck at allowoverride

Go to End

3 Posts   3090 Views


Community Member, 68 Posts

13 February 2009 at 11:35pm

First of all, i must say from the demo, that SS looks very promising.
I would like to test it out on my own server and have tried to install, but stumbled upon some problems and require assistance from you guys.
My hosting fullfils all requirements and has mod rewrite enabled.

Let me tell you what i did and display the errors:
1. Uploaded the files

2. edited .htaccess (as i got an parse error before and have added: AddType x-mapp-php5 .php and AddHandler application/x-httpd-php5 .php

3. opened index.php file on my hosting and filled info for database and admin settings. All checks were ok, apart from two:
Server software (SS couldnt say what webserver im using, but i know im using apache)
mod_rewrite enabled (SS couldnt say this, but according to my hosting company this is enabled, and can be further controlled by entries in .htaccess file

4. started the installation

5. Error with openid occured:

Warning: require_once(Auth/OpenID/Consumer.php) [function.require-once]: failed to open stream: No such file or directory in /blabla/blabla/www/ on line 24

Fatal error: require_once() [function.require]: Failed opening required 'Auth/OpenID/Consumer.php' (include_path='.:/usr/local/php5-cgi/include:/usr/local/php5-cgi/lib:/conf/php/php5/pear:/blabla/blabla/www/') in /blabla/blabla/www/ on line 24

6. as i dont need openid authorisation, i followed somebody's suggestion to delete the "auth_openid" directory, brought back the .htaccess to the state from point 2 and restarted install.php

my .htaccess looked like this:
<IfModule mod_dir.c>
DirectorySlash Off

RewriteEngine On
RewriteBase /ztm

RewriteCond %{REQUEST_URI} !(\.gif)|(\.jpg)|(\.png)|(\.css)|(\.js)|(\.php)$

RewriteCond %{REQUEST_URI} ^(.*)$
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule .* sapphire/main.php?url=%1&%{QUERY_STRING} [L]

7. got an error This time it tooks SS a longer time to install after i clicked on install button.

Warning: file_get_contents( [function.file-get-contents]: failed to open stream: HTTP request failed! HTTP/1.1 404 Not Found in /blabla/blabla/www/ on line 47
mod_rewrite doesn't appear to be working. Make sure:

* mod_rewrite is enabled in your httpd.conf
* AllowOverride is enabled for the current path.

when i clicked to proceeed anyway, after brief info that all went ok, i got this:

Parse error: syntax error, unexpected T_STATIC, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in /blabla/blabla/www/ on line 35

Is there a way somebody could assist ? it looks to me i have come through some difficult stages and this one might appear as the last obstacle to get SS successfully installed, but i dont have the solution.



Community Member, 68 Posts

15 February 2009 at 10:36am

Edited: 15/02/2009 10:09pm

is there anybody who could help me ?
in the meantime, i have found out from my hosting company, that allowoverride is enabled as well.
I have no idea where am i doing something wrong and my client wants me to set up his website over the next week.

Additionally, I have noticed that after i "force" installation following that screen about mod-rewrite, i briefly see that installation was successful and i end up with more or less that same error message (listed in the post above) as at the beginning (parse error).

after i call again the directory where SS is installed, i get either 400 Bad request or Internal server error.

Would appreciate any tips from you guys out there.



Community Member, 68 Posts

24 February 2009 at 3:40am

Just to let you know how i solved my problem.

In the control panel of my hosting, i set to treat all .php files as php5, one level higher than where i was installing SS.
so when i was installing it at i set the php5 on level of

Then, the whole installation process went smooth