Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Warnings after Installation on the WebServer


Go to End


13 Posts   5964 Views

Avatar
steve_nyhof

Community Member, 224 Posts

15 March 2009 at 5:35pm

Edited: 15/03/2009 5:36pm

Trying to get 2.3.0 working now...
I got a little further by doing as instructed per Sam. However, I am getting the the error below.
I have submitted a ticket for this to my host (reseller account). However, is there anything I can do to get past this?
.
.
.

Installing SilverStripe...
I am now running through the installation steps (this should take about 30 seconds)

If you receive a fatal error, refresh this page to continue the installation

Creating 'mysite/_config.php' for use with _ss_environment.php...
Creating /home/aliyswor/public_html/mysite/_config.php
Creating '.htaccess' file...
Creating /home/aliyswor/public_html/.htaccess
Building database schema...
Checking that friendly URLs work...
Friendly URLs are not working. This is most likely because mod_rewrite isn't configuredcorrectly on your site. Please check the following things in your Apache configuration; you may need to get your web host or server administrator to do this for you:
mod_rewrite is enabled
AllowOverride All is set for your directory

Avatar
jonas

Community Member, 1 Post

21 August 2015 at 2:28am

Edited: 21/08/2015 2:32am

@ Froshi: I had same error: Fatal error: SS_DATABASE_PASSWORD must be defined in your _ss_environment.php.
and it was simply due because PHP tags was missed: <?PHP ?> in _ss_environnement.php file.
It should solve the issue.

Avatar
motoservo

Community Member, 27 Posts

23 August 2015 at 11:22am

Just had the same issue because I was following the instructions "to the T". Adding the tags got me back. Thanks, Jonas.

Avatar
Graveris

Community Member, 1 Post

17 September 2015 at 1:20am

The same issue.... No solution?

Avatar
motoservo

Community Member, 27 Posts

17 September 2015 at 1:27am

Well, the fix for me was as jonas posted. Just add the <?php tag. Somehow, I'd forgotten it because I didn't see it mentioned in the instructions.

Go to Top