Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Unix to Windows migration - CMS Login not working

Go to End

16 Posts   5144 Views


Community Member, 904 Posts

31 October 2009 at 4:53am

That's strange. The error regarding the session is most likely because some content is written before the session started. Make sure you don't have any whitespace (or other content) before <?php and after ?> in your _config.php.

When did you enable the Translatable extension? Did you have a working site before?


Forum Moderator, 435 Posts

31 October 2009 at 9:23am

Edited: 31/10/2009 10:05am


There isn't space before <?php and after in _config.php.
I had not this problem before...
Yes, this is a beta site to rc0..


Forum Moderator, 435 Posts

2 November 2009 at 9:58pm

I resolved the problem, but I don't know what happened...
I had reinstall SS ( without copy files and databases ) using install.php.
After that , SS goes ok.
I seen before this step that .htaccess was empty!
Why? Is a SS bug?


Forum Moderator, 435 Posts

26 December 2009 at 11:48pm


I had the same problem with another site, but this time I remember what's happen.
We have this type of error when you made this steps:

- upload a changed php class file
- you aren't admin logged
- you haven't setup defaul admin in config.php

then you launch build command.

For recovery from this error, you must upload install file and made setup.



Community Member, 54 Posts

8 January 2010 at 4:27pm

I had the same problem and ran install.php too.

I then noticed the following in _ss_environment.php


I bet this overrides the Security::setDefaultAdmin in _config.php ... if someone confirms perhaps update the following page


Community Member, 2 Posts

13 January 2010 at 5:26pm

I am having issues accessing CMS on windows 2008.

If I go to /admin I get 404 Not Found. If I go to /Security/Login I can enter the login name and password but then I get page cannot be displayed. I have entered Security::setDefaultAdmin("username", "password"); in /mysite/_config.php still unable to login.

I have re-installed, tried everything that has been suggested on the other forum posts and still no access to CMS.

The website works great with this one exception, I can see a lot of people have had this problem but I can't seem to find out if anyone has ever managed to get it resolved? Does anyone have any clues on what else I can be looking at?

Many thanks in advance for any help.


Community Member, 63 Posts

15 January 2010 at 12:06am


Have you tried to access the cms on another web browser?

Reason I ask is we have had rogue problems logging into sites via IE 8 and it appears to be down to the Addons on IE8. Dont know which addons are causing the hiccups but some seam to affect the ability to login.

You may have already tried another browser but thought I would suggest it.



Community Member, 2 Posts

15 January 2010 at 9:41am

Hi Chris,

I have tried Firefox, Opera and IE7, and the same thing happens on all of them. I have done a clean install to make sure it was nothing in my customisation, the rewrite seems to be working as all the menu links on the website works but I cannot access the admin in anyway.

Anything else you might be able to suggest. I am really keen on using silverstripe but its a bit of a problem if I can't add any content.

Thanks for you suggestion any more ideas are much appreciated :-)



Go to Top