Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Local Install on Windows Vista

Go to End

7 Posts   4002 Views


Community Member, 9 Posts

21 March 2009 at 5:02am

Edited: 21/03/2009 5:02am

Okay, here's my setup:

-Windows Vista/Apache 2.2/PHP 5.2.8/MySQL 5.0

I'm simply attempting to do a local install (Apache is running on 8080).

When I attempt to do this without running Apache as an administrator I get an entire page of these errors:

Warning: fopen(C:\Users\myusername\AppData\Local\Temp\/silverstripe-cacheC--Users-myusername-Documents-ApacheRoot-webapptests-SilverStripe-SilverStripe-v2.3.0/manifestClassParse-C__Users_myusername_Documents_ApacheRoot_webapptests_SilverStripe_SilverStripe-v2.3.0_cms_code_AssetAdmin.php) [function.fopen]: failed to open stream: No error in C:\Users\myusername\Documents\ApacheRoot\webapptests\SilverStripe\SilverStripe-v2.3.0\sapphire\core\ManifestBuilder.php on line 398

It does this roughly 20 times for different files (this one appears to be for AssetAdmin.php).

Then, if I run my local Apache server as an administrator, (using "Run as Administrator" in the context menu) everything seems to work fine, until it actually starts creating files, and then it eventually just breaks down into exactly what I ended up with when just trying to browse to the SilverStripe directory without running as an admin.

...err, so what the heck? I've installed any number of CMS's locally on Vista without a single hitch (Drupal, Joomla, Wordpress, etc.). So what's going on here? What is Silverstripe even trying to do in ManifestBuilder.php on line 398? This is just sort of silly.

I'm just trying to evaluate SilverStripe and I can't even get it to install. This is silly. I'd start by thinking that the "\/" in the path I'm seeing in the warning might be part of it... but...?


Community Member, 9 Posts

21 March 2009 at 5:14am

...more info...

I thought perhaps I'd have more luck with SilverStripe 2.3.1 (I was installing 2.3.0 before) and now i just get this when navigating to the SilverStripe directory:

Parse error: syntax error, unexpected $end in C:\Users\myusername\Documents\ApacheRoot\webapptests\SilverStripe\SilverStripe-v2.3.1\sapphire\dev\install\config-form.html on line 178

...? Any thoughts?


Community Member, 1 Post

21 March 2009 at 11:47am

So I fixed the last error you listed, regarding the parse error, by eliminating the tag-soup in the config-info page. I'm not really sure why it was an issue, all of the braces looked correct after I made it all PHP (instead of breaking in and out of PHP).

I'd post the solution except that shortly after, when trying to install, I got the first issue you mentioned with all of the errors opening files. I'm also running on Windows (Vista) and I would be extremely disappointed if the issue was just that the Sapphire core wasn't written with Windows 'slashes' in mind. What a silly thing to overlook.

The fact that its not plastered all over these boards, though, tells me that theres very few windows devs here or that it's probably a Vista only issue (why?)

Weird. Guess I won't be looking into Silverstripe just yet.


Community Member, 9 Posts

25 March 2009 at 3:04am

Edited: 25/03/2009 3:06am

Thanks for fixing the error.


It's just unsettling that SilverStripe is so tied to a particular setup. It doesn't seem particularly robust. Yeah, I know running sites in Windows isn't great, but there's no reason not to support it, especially since any other CMSs will do so. Even if people hate windows, it's a decent enough environment for web scripting and development, (give it a break, sheesh). If it is just a forward/backwards slash issue, that's just lame.

...I mean, the design here at this site is cute and all (I can only assume runs on SilverStripe), but, sheesh, I have misgivings about what's running underneath it. You can easily build nice looking stuff on any system.


Forum Moderator, 628 Posts

31 March 2009 at 4:32pm

You have some PHP / Windows / Apache environment issue that needs to be sorted out. 40% of installs happen on Windows and many work, but some hit errors like this that we often can't replicate at our end.

For this very reason we worked with Microsoft to better support IIS on Windows support, see our blog. I realise you already have Apache running on your machine, but you might like to give that a try--I've installed it several times at my end successfully using WebPI.


Community Member, 9 Posts

28 July 2009 at 8:58am

Edited: 28/07/2009 9:09am

Hrrm, I dunno what the deal is yet but I've managed to get SilverStripe humming perfectly by changing line 115 in sapphire/core/Core.php

I changed:

if(!defined('TEMP_FOLDER')) {
define('TEMP_FOLDER', getTempFolder());

if(!defined('TEMP_FOLDER')) {
define('TEMP_FOLDER', 'C:\\path\\to\\my\\temp\\folder');
} guess is that the getTempFolder() function simply isn't forming TEMP_FOLDER correctly for whatever reason. I can't see why this is just yet.

I still don't really see how this could be a configuration issue. It still seems like SilverStripe is improperly sticking that extra slash at the end of TEMP_FOLDER. I mean, is there any conceivable configuration issue that would just stick a slash at the end of the TEMP_FOLDER for some reason?

If there is, that'd be the problem. Probably worth sorting out. It'd make that Web PI business a bit unnecessary then if I can just continue using a WAMP environment locally on Vista.


Community Member, 9 Posts

29 July 2009 at 12:47am

Edited: 29/07/2009 12:53am


After reading the getTempFolder() function, it seems I can just put a "silverstripe-cache" folder in the installation directory. there some reason this doesn't seem to be anywhere in the documentation? Coulda saved me a load o' time. :)

...anyways, to anyone else having a similar problem, just make a "silverstripe-cache" folder in your installation directory and give write permissions to it. From the code, as far as I can tell, if you have this folder in your install directory, SilverStripe will use this as your temp directory before it tries to use your system's temp folder.

This will completely sidestep this whole slash issue I was getting, but still seems as if there's something odd going on in that function that makes it less than environment agnostic.