Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

2.3.1 install file broken

Go to End

19 Posts   7403 Views

Carbon Crayon

Community Member, 598 Posts

21 March 2009 at 12:24pm

Edited: 26/03/2009 12:57am

Just tried to install 2.3.1 and it looks like the sapphire/dev/install/config-form.html is missing some php start tags. I made the following fixes and it works

line 62 & 63

<li>........checked="checked"<?}?> ><label for="EmptyTemplate">..........</li>


<li>........checked="checked"<?php } ?> ><label for="EmptyTemplate">..........</li>

Bruce B

Community Member, 164 Posts

23 March 2009 at 12:02pm

thanks for this post. This error happened after 2.3.1 rc2. On my version it was lines 58 and 59 that both needed the change.


Administrator, 690 Posts

23 March 2009 at 12:12pm

Hi all,

This will only cause an error if short_open_tags is set to off, which is how it slipped through the cracks. We have since added automated tests that will attempt to parse the files with short_open_tags both off and on, which will stop this error from getting into a release in the future.

The fix will be released in 2.3.2; in the meantime everyone suffering from this problem should use Aram's fix.



Community Member, 48 Posts

23 March 2009 at 2:21pm

Small correction:

file location is:


cheers Dave


Community Member, 1 Post

25 March 2009 at 8:52am

Thanks Aram, I've never setup a SS site before so to find a problem in the install file didn't fill me with a lot of confidence from the get go.
Also, Thanks Sam for explaining the problem and putting it into context.

I was worried for a second there that I was going to have as much trouble as I did setting up a typo3 site!

Sound like this is a great support forum already!

Carbon Crayon

Community Member, 598 Posts

26 March 2009 at 12:56am

thanks for the correction daveP, added to my original post :)


Community Member, 1 Post

30 March 2009 at 5:12am

hello and good day

i have tried instaling but i still get an error
Parse error: syntax error, unexpected $end in C:\wamp\www\silverstripe\sapphire\dev\install\config-form.html on line 178

do you have the good source cose for this fils
{tried changing as stated in this thread

please advice
thank you

Carbon Crayon

Community Member, 598 Posts

30 March 2009 at 6:18am

Hi Azul

Make sure you have changed both lines and that there are spaces inbetween the tags and the }. So it should be:


that will work :)

Go to Top