Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

problem with ss 2.3.1

Go to End

7 Posts   2170 Views


Community Member, 211 Posts

23 March 2009 at 6:14am

Edited: 23/03/2009 6:27am


I'm really getting mad with this install, and I have been redaing lost of post and suggestion.

So once agin here is my problem.

After I get all the green light I install the black candy option.
Once I press "install ss" it goes to the install pages wich title is "php5 needed" the the page goes like this :
And the nothing and if I triy to go inside the folder I get either nothing or back to the install page wich says that ss is alreay installed.

I noticed that in some case I get A error 500 page

I want to use silverstripe for a client but I'm wooried now because from the checklist page evrything is ok from having the right PHP version to folder and files autorisation

Maybe I did not get something regarding what to do once it is installed but as I was saying I don't get anything saying "install is finished "

Please help

Thank you

------------------------------ PAGE -----------------------------
Installing SilverStripe...

I am now running through the installation steps (this should take about 30 seconds)

If you receive a fatal error, refresh this page to continue the installation

* Creating 'mysite/_config.php'...
* Creating /var/www/vhosts/
* Creating '.htaccess' file...
* Creating /var/www/vhosts/


Community Member, 5 Posts

24 March 2009 at 12:10am

Hi there!

I'm facing the same problem as described above. Local installations on MAMP work flawlessly, but installing on a VServer (HostEurope in Germany) won't work, no matter what I've tried. The checklist contained only green items none of them was orange... All the directories are writable, the database connection is made...

Does anyone have a clue what could be wrong?


PS: I posted the same issue in the german »«-Forum:


Community Member, 211 Posts

24 March 2009 at 3:17am


I want trough the install files and things seems to be fine (themes installed, folders etc)
so I guess There is somtehing wrong accssing alls this so here is teh coontent fo my _config.php file and of the htaccess file if anyone can help ;)

thank you

---------------------------- _config.php

global $project;
$project = 'mysite';

global $databaseConfig;
$databaseConfig = array(
"type" => "MySQLDatabase",
"server" => "localhost",
"username" => "mysuername",
"password" => "mypassword",
"database" => "basedelair_",

// Sites running on the following servers will be
// run in development mode. See
// for a description of what dev mode does.

// This line set's the current theme. More themes can be
// downloaded from


--------------------------------------------------- htaccess
<Files *.ss>
Order deny,allow
Deny from all
Allow from

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /SilverStripe

RewriteCond %{REQUEST_URI} !(\.gif)|(\.jpg)|(\.png)|(\.css)|(\.js)|(\.php)$

RewriteCond %{REQUEST_URI} ^(.*)$
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule .* sapphire/main.php?url=%1&%{QUERY_STRING} [L]


Community Member, 211 Posts

31 March 2009 at 10:09pm

Hello again

I'm very dispointed with ss and the forums.

I have an issue with the install tough evrything is GREEN (like I said in my first post), but at the end the isntall stop with no error message. It just stops like that.

Then no one is even trying to help me with that or at least giving me a hint about my pblms.

If only I had an error message and things to correct it woulb great.

I think that SS is a great soft when installed (I did a 2.2.3 install taht worked fine) but now I'm having problems with some clients because I'm unable to make it work.

So if anyone has an idea please help me, I can provide any file or access needed

Thank You



Community Member, 5 Posts

31 March 2009 at 10:50pm

Hey Thomas,

i'm with you. I'm experiencing the same problem as I wrote above and nothing really worked. I'm developing on a local installation with MAMP where everything just works. But in the next days I'll have to put those things on a »real« webserver, so I would also like this problem to be solved.

Since I don't think that this is a rather heavy configuration problem on our sides, I've created an ticket explaning this »bug«. No reply until now, but you can find this ticket here:

So, I'm a little disappointed by the forums, too. But maybe some user or even the someone of the developer gets attention to this problem, since this thread grows a little. I would deeply appreciate that...

Best wishes from Germany!



Community Member, 1 Post

2 April 2009 at 3:18am


Had the same problem. Looking through the logs it was having an issue with safe mode. Turn safe mode off in your php.ini files and the installation continues (well, it did in my situation).

Hope it helps,


Community Member, 211 Posts

2 April 2009 at 4:43am


There is something that is not checked by the "greenlight" page and that is php safe mod.
It seems to have to be on off otherwise it is blocking the end of process install

Thank a lot woop