Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Cannot login thru admin page


Go to End


4 Posts   2491 Views

Avatar
stinkytofu

Community Member, 17 Posts

26 March 2009 at 6:58pm

We have just installed Silverstripe, right now, we are able to view and navigate thru the entire website - so I assume that mod_rewrite is working properly. However, when we try to login through the admin interface, we just get redirected back to the login page, with a message saying "You're logged in as Admin." We are unable to access the CMS itself, as we keep getting directed back to the login page after a successful login.

Here are the contents of the .htaccess file:

### SILVERSTRIPE START ###
RewriteEngine On
RewriteBase /

RewriteCond %{REQUEST_URI} !(\.gif)|(\.jpg)|(\.png)|(\.css)|(\.js)|(\.php)$

RewriteCond %{REQUEST_URI} ^(.*)$
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule .* sapphire/main.php?url=%1&%{QUERY_STRING} [L]
### SILVERSTRIPE END ###

Any idea what the problem may be?

Avatar
stinkytofu

Community Member, 17 Posts

28 March 2009 at 4:44am

Anyone have any idea about this? I'm still struggling to get the CMS login working. It still loads a blank page.

Help me Obi-wan! You're our only hope!

Avatar
peterf

Community Member, 8 Posts

28 March 2009 at 8:49am

I hear your pain.

I installed a week or so back and encountered a similar problem. When you installed you were given the option of using a user name or an email address as your preferred login method. I tried the user name option but then could not subsequently log in. I reinstalled using the email address option and have had no further problems. Worth a try?

Avatar
stinkytofu

Community Member, 17 Posts

28 March 2009 at 9:50pm

Thanks Peter. Turns out it was a memory configuration problem with the server.

Just needed to increase PHP allocated memory size to 64MB and it works fine now.