Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

new install does not allow me to log in

Go to End

3 Posts   1643 Views


Community Member, 6 Posts

3 April 2009 at 9:59am

I have been repeatedly installing silverstripe on linux/apache. The install goes smoothly, but I cannot log in to the cms.
I have tried setting this line in mysite/_config:
[code php] Security::setDefaultAdmin($username, $password);
And these credentials don't allow me to log in either.

How can I log in ?


Community Member, 8 Posts

5 April 2009 at 3:14am

I have exactly the same problem. Site is visible, but can't get in to the CMS. The email I specified as admin during install is not recognised (I've tried the "forgot my password" route.)

I had this problem with v2.2.3 and lost interest for a while. Came back it this week and installed 2.3.1 but exactly the same thing happens.

Having had another problem with even getting 2.3.1 installed, I'm beginning to think maybe SS isn't ready for "consumer" use. These days, you don't expect to spend days trying to get a CMS working. I've installed several other systems in recent months, all without a hitch.



Community Member, 18 Posts

17 May 2010 at 9:14am

I had the same problem. After a fresh install i was not able to login into the cms. I was being redirected to he login page every time i tried to log in. I spoke with my hosting provider to increase the allocated PHP memory to 64Mb.

It is working for now. I hope this helps people who are having similar problems.