Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We've moved the forum!

Please use for any new questions (announcement).
The forum archive will stick around, but will be read only.

You can also use our Slack channel or StackOverflow to ask for help.
Check out our community overview for more options to contribute.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

403 Error on install

Go to End

4 Posts   4347 Views

Mike Mairangi

Community Member, 8 Posts

29 April 2009 at 2:00pm

Edited: 29/04/2009 2:39pm

I've successfull installed Silverstripe onto my hosting company's server and accessed the CMS to modify the home page from the install page however when I try and access either the home page or the login page I get a 403 Forbidden error-

You do not have permission to access this document.

I've checked all the file permissions and they seem ok so I'm stuck as to what to do next.

Any help would be much appreciated.



BTW I loaded a basic index.html file to test the host and this worked ok.


Community Member, 607 Posts

29 April 2009 at 11:46pm

Edited: 29/04/2009 11:47pm

This often has something to do with .htaccess and the server not agreeing with something in there.

Try commenting out commands in that file (use # to comment). Start with the RewriteBase / line.

Failing that, try adding this to the top of your .htaccess.

php_value memory_limit 64M 
php_value allow_call_time_pass_reference 1

<IfModule mod_security.c>
SecFilterEngine Off
SecFilterScanPOST Off

Make sure you backup the original in case this isn't the cause of the problem.



Community Member, 607 Posts

29 April 2009 at 11:51pm

Ignore what I said in my last post for now - I was thinking 500 errors.

Can you add this to your .htaccess:

Options FollowSymLinks

Let us know.

Mike Mairangi

Community Member, 8 Posts

30 April 2009 at 7:16am

Edited: 30/04/2009 7:17am

Thanks Aaron!

I had created a folder, silver, under the httpdocs root directory with all files stored under this. The hosting company told me that because as I didn't have an index file under httpdocs there was nothing to start the application. They also changed permissions on .htaccess to 644?

Everything works ok but only if I add /silver or /silver/admin to the URL. I've tried moving everything to the root directory httpdocs and removing index.html but this stops everything. I'm sure there must be a simple solution to this but I'm lost as to what it is unless your - Options FollowSymLinks - solves this?

Thanks a million!