Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Installation stops at "PHP 5 is required"

Go to End

12 Posts   6274 Views


Community Member, 3 Posts

16 May 2009 at 7:34pm

Edited: 17/05/2009 6:22am

Hey ppl,

i just found SS and thought, great framework plus CMS? i wanna test that ;) ... so i downloaded the latest stable (2.3.1) and uploaded it onto my server (debian etch).

so far, so good. after entering the database credentials all went green - besides the SS-Installer cant tell, if mod_rewrite is active. i tried to install SS anyway, 'cause I know it works (typo3 and some shop systems are running on that server, using mod_rewrite).

After clicking 'Install' the installer stops after telling me, that 'friendly URL's are not working - try ...... ' and the website title yields 'PHP 5 is required', though the previous page told me 'PHP5 installed OK (PHP version 5.2.0-8+etch13)'

I'm now a little bit confused, if its a mod_rewrite error or a PHP error, because normally both requirements are met and work in other contexts.

thanks for helping me out on this one :)

Attached Files

Community Member, 3 Posts

9 June 2009 at 8:36pm

Exactly the same happened to me - frustrating. I really want to support this system being a New Zealander and all!


Community Member, 400 Posts

24 June 2009 at 5:40pm

are you sure about you have enabled the mod_rewrite?


Community Member, 40 Posts

27 June 2009 at 6:10pm

Edited: 27/06/2009 6:10pm

I had a similar problem, I had the domain I installed SS on running in FastCGI mode instead of Apache Mode (Plesk Based admin), as I originally had a rails app here. Then I tried the install again and it failed, I look at the logs and I could not access tmp files as fastCGI must handle temp files differently. The owner of the tmp file was not apache; therefore the site could not access the temp file. Once I deleted the temp file and re-ran the installation, I was back in business, as the temp file was recreated with correct permissions.

I am lucky enough to be the owner of my own hosting company, however I am sure if you submit the problem to your hosting provider with my suggestion you might be in luck.

I hope you can learn from my experience. Loving SilverStripe up to my forth roll out.


Administrator, 690 Posts

28 June 2009 at 12:00pm

There's an enhancement ticket that will help make this issue easier to debug -

I've bumped its priority a little, since it seems like this affects a lot of people in various ways, and its usually quite confusing.


Community Member, 3 Posts

30 June 2009 at 9:06pm

Edited: 30/06/2009 9:20pm

The solution to this for me was in the httpd.conf file where I had installed SilverStripe initially in a folder named /silverstripe-v2.2.2 and then more recently renamed it to /SilverStripe. In httpd.conf found the <Directory ...> entry for SilverStripe & changed the entry reflect the change in the folder name. And attempted a re-install, ... success!! :) This forum helped me find the solution.

Now I have the issue of not seeing the home page of my SilverStripe site :( . Continuing to check the forum for how to resolve this.

Gravitational FX

Community Member, 22 Posts

10 July 2009 at 6:29am

Edited: 10/07/2009 6:50am

I'm having the same problem.

Hosting company is and they seem to use the FastCGI for the scripting.

FTP'd up the SS232, ran install.
Got a server 500 error. Would only run after I commented out these lines in the root .htaccess file

<Files *.ss>
#Order deny,allow
#Deny from all
#Allow from

Then midway through installing it hangs in the Testing... with the browser status saying "PHP 5 is required" (it is installed).
When trying to run install.php it now complains about the /sapphire/.htaccess so I have to comment all of those out too.

Once that is done I can see the Home page, but the CSS is not being rendered and no graphics are being displayed.

I've attached the logfile if it's any help (start from July 9th)

Don't know what to do and my customer is getting ratty :-(

Help would be very much appreciated.

Attached Files

Community Member, 7 Posts

16 July 2009 at 3:30am

In my hosting environment, they still run PHP4 as the default version. I need to add...

# Use PHP5 as default
AddHandler application/x-httpd-php5 .php the top of my .htaccess file in the root to get the server to run SS using PHP5.

The finished .htaccess file contains:

# Use PHP5 as default
AddHandler application/x-httpd-php5 .php

<Files *.ss>
Order deny,allow
Deny from all
Allow from

<IfModule mod_rewrite.c>
RewriteEngine On

RewriteCond %{REQUEST_URI} !(\.gif$)|(\.jpg$)|(\.png$)|(\.css$)|(\.js$)|(\.php$) 

RewriteCond %{REQUEST_URI} ^(.*)$
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule .* sapphire/main.php?url=%1&%{QUERY_STRING} [L]

Go to Top