Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

silverstripe-cache missing: WPI install on Vista x64


Go to End


3 Posts   2866 Views

Avatar
knigjes

Community Member, 3 Posts

1 June 2009 at 3:59pm

Edited: 01/06/2009 4:01pm

I installed SilverStripe using the newest recommended method.

everything complete without errors, but when I clicked "Launch you web application now" I got:
PHP Fatal error: Permission problem gaining access to a temp folder. Please create a folder named silverstripe-cache in the base folder of the installation and ensure it has the correct permissions in C:\inetpub\wwwroot\silverstripe\sapphire\core\Core.php on line 230

So I created a folder: C:\inetpub\wwwroot\silverstripe\silverstripe-cache
when I refresh http://localhost/silverstripe/index.php
I get 295 PHP errors, all referring to line 398 of: C:\inetpub\wwwroot\silverstripe\sapphire\core\ManifestBuilder.php
and ending with :
PHP Fatal error: Cannot write manifest file! Check permissions of C:\inetpub\wwwroot\silverstripe/silverstripe-cache/manifest-main in C:\inetpub\wwwroot\silverstripe\sapphire\core\ManifestBuilder.php on line 105

Avatar
knigjes

Community Member, 3 Posts

2 June 2009 at 4:21pm

anybody know the proper directory structure of a clean install with default settings?
Also - are there other components to a correct install - registry entries or database integration that I should check for?

Avatar
knigjes

Community Member, 3 Posts

2 June 2009 at 6:54pm

FIXED:

I reset the permissions in the security tab

First tried using an elevated cmd prompt to un-set Read Only (just to make sure) - that had no effect
Second, I right clicked on the folder -> Properties -> Security Tab, and set all the permissions to Full Access for each user. At first I tried just IIS users, but that didn't work so I just gave them all access. Silverlight completed it's install and I'm good now.