Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba


Go to End

7 Posts   2095 Views


Community Member, 4 Posts

27 June 2009 at 8:27pm


Where is installation instruction for Googlesitemaps module? Does it work at all? What to do to force it to work?

Please help!



Community Member, 4 Posts

16 October 2009 at 6:59am

Assuming you use the latest version of SS:

Download the latest build here:

(FTP to your ss site): Overwrite all files in the googlesitemaps directory with the new ones you just download
then browse to: http://yourwebsite/db/build

then login to http://yourwebsite/admin

the UI of google site maps ranking is there. Now you have the following problem: "sitemap.xml is not being generated"

I don't know how to solve this, but maybe someone else can. Please let me know.

Fred Condo

Community Member, 29 Posts

16 October 2009 at 8:07am

Call the following method in your mysite/_config.php:



Community Member, 4 Posts

16 October 2009 at 10:04am

Edited: 16/10/2009 10:05am

Thank you for the quick reply:

Here's how I changed the _config.php located in the mysite folder:


global $project;
$project = 'mysite';

global $databaseConfig;
$databaseConfig = array(
"type" => "MySQLDatabase",
"server" => "localhost",
"username" => "***",
"password" => "**",
"database" => "***",

// Sites running on the following servers will be
// run in development mode. See
// for a description of what dev mode does.

// This line set's the current theme. More themes can be
// downloaded from

//enabling 3rd party software


Still no sitemap.xml :(. I have CHMOD the root folder to 777, flushed the site and logged in and clicked save on a page. Still no effect. Any ideas?

Fred Condo

Community Member, 29 Posts

17 October 2009 at 4:11am

Unfortunately it Just Works on my installations—but then I'm using the version of the module that's bundled with SilverStripe 2.3.3.


Community Member, 24 Posts

29 April 2013 at 8:35pm

Edited: 29/04/2013 8:36pm

Hi all,

I keep trying to make the google sitemap work. In the website I have installed a googlesite moudule for the pages of the site, and then installed a wordpress blog, which means I need to submit two sitemap.xml files.
(Using ss3 and the master googlesitemap module)
My questions are two:

I am getting a 500 internal error saying: GoogleSitemapController::$allowed_actions must be public. I read on github that static configurables properties need to be private. Does it have to be public?????

How do I submit separately the two sitemap.xml files? Do i need a separate googlesitemap module for the wordpress blog?

Please help!!


Forum Moderator, 5523 Posts

3 May 2013 at 9:16pm

You'll need to download the supported version for your module. Master supports 3.1, 1.1 supports 3.0 (