Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Problem with install.php SS version 2.3.2

Go to End

4 Posts   2625 Views


Community Member, 61 Posts

8 July 2009 at 11:44am

Edited: 08/07/2009 11:50am

I am trying to install silverstripe on an apache webserver but the install.php page is not letting me as there are permissions errors that aren't going away.
When I first go to the install.php page I get error messages for three files that it says apache is unable to write to the files/folders are ".htaccess", "mysite/_config.php", and "assets". So when I go into the server and change the permissions on these files and reload the install.php page the error for the "assets" folder goes away but the others stay. I've tried changing various permissions on the files and it still doesn't work. Some of the things that I have tried are making apache the owner of the files, changing the files permissions to "777" and changing the permissions for the directory that the files are in to "777". I have also done the steps that are on the "Silverstripe server requirements" page.
So the problem must be somewhere else in linux with some other configuration. Please if anyone has encountered this problem before or knows some possibilities of things that may be affecting this let me know.

Thanks Liam.


Community Member, 181 Posts

8 July 2009 at 2:22pm

Setting the permissions on these should be straight forward but you're obviously encountering an issue.

First, the difference between assets and the other two that are failing is that assets is a directory and the others are files. I can't think of any apache directives that could affect this.

Permissions of 777 should allow pretty much anything, can you check that these files actually exist? also try adding write permission for the web server user to the directory SS is in and the mysite directory.




Community Member, 61 Posts

8 July 2009 at 3:54pm

Thanks for the reply. After many hours of trying to get this fixed I finally got it to work with the help of "mobiusnz\work" from the silverstripe irc channel. I dont know how unique this problem is but I will write what the problem was, hopefully this will help someone.

The problem was to do with SElinux which is "Security Enhanced Linux" a feature that comes with linux and since I was using Fedora it is by default set to enforce and obviously doesn't allow for things like silverstripe to write to files. So to get silverstripe to work I had to run this command "chcon -R -t httpd_sys_content_t /var/www/silvertriperoot/".
As far as I know what the command does is disable SElinux enforcing whatever it does on that directory, therefore allowing silverstripe to write to the files that it needs.

So a big thank you to "mobiusnz\work" for finally getting this to work.



Community Member, 54 Posts

8 July 2009 at 3:57pm

Hi lanks, no problem. Thanks for posting the solution up here so others can give it a shot if they have the same problem.