Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Apple Macintosh install and operational issues

Go to End

23 Posts   5483 Views


Community Member, 6 Posts

10 July 2009 at 5:34pm

How do I deploy new page templates (Homepage.php, eg) on a Macintosh system running MAMP and SS?

I can't get the http://localhost/dev/build/?flush=1 command to work, updating the page type template as per tutorial 1 section 'Creating a new page'. I've tried using the port numbers of apache server and mySQL server (8888 and 8889 resp.) and get different results but none succeed in updating the page types in CMS.

With no port spec, I get:

Safari can’t connect to the server.
Safari can’t open the page “http://localhost/dev/build?flush=1” because Safari can’t connect to the server “localhost”.

With localhost:8889 (mySQL) I get

a little downloaded text file that has some gobbledygook and then 'Bad Handshake'

with localhost:8888 (Apache) I get

Not Found
The requested URL /dev/build was not found on this server.
Apache/2.0.59 (Unix) PHP/5.2.6 DAV/2 Server at localhost Port 888

Is there some other security setting I need to adjust perhaps?

I am not a developer or IT specialist, I come to this from graphics and comms side, but know my way around the tech side too. Any help appreciated, happy to provide more details as needed.

OS X 10.5.7 Leopard
MAMP and SS latest downloads, just installed this week


Forum Moderator, 5523 Posts

11 July 2009 at 3:52pm

How I configure my MAMP is apache to port 88. Leave mysql with whatever it chooses. I also set the Document Root (in prefs) for mamp to /Users/Will/Sites/ rather then the default one inside MAMP folder. Then it should just be a simple task of reseting mamp (as you have edited the ports) and visiting http://localhost/. Then each site is setup as a folder in /Users/Will/Sites/*

Make sure when you move files around in OSX you move the .htaccess file as well. By default this file will be hidden so you need to turn hidden files off or move it via Terminal (if you have to move it with the mv command - mv /path/to/.htaccess /path/.htaccess. I think this is whats causing your last error.


Community Member, 6 Posts

12 July 2009 at 8:03am

will what string to you use for dev/build/?flush ? That the part that's not working. i can edit the site and view in browser no problems, its only updating database with new page types thats failing.


Community Member, 904 Posts

12 July 2009 at 11:46am

I'm developing on mamp too. You should simply use dev/build, works fine here.


Community Member, 6 Posts

12 July 2009 at 12:58pm

Can anyone on Mac using MAMP please supply the full URL for this dev/build flush? I have changed MAMP to default ports, 80 for Apache, but still can't get the new page type to show up in CMS. I get stuck at the step after creating a new PHP file for homepage type -- its in code folder but won't appear in CMS editor as page type choice -- the dev/build doesnt seem to be working.

I have tried: http://localhost/dev/build?flush=1


http://localhost:3036/dev/build?flush=1 (MySQL port)

also tried to flush the SS cache afterwards to see if that helped, but no.


Forum Moderator, 5523 Posts

12 July 2009 at 4:04pm

Ok so in my Environment sites are located /Users/Will/Sites/SiteName/
The MAMP Root is set to /Users/Will/Sites
So my dev/build URL is http://localhost/SiteName/dev/build/

You should see a List of Tables when running dev/build. If you see a blank page or something else then it did not work.


Community Member, 6 Posts

12 July 2009 at 4:44pm

OK, my MAMP root is /Users/jungle/Sites/htdocs

inside of htdocs is /silverstripe/silverstripe-v.2.3.2/[unzipped all files here]

I tried all combos i could think of but none seemed to work, no tables listed in browser window.


reports apache not found on server 404 error, as do all other combos now that i'm on port 80

this is my path to CMS editing http://localhost:80/silverstripe/SilverStripe-v2.3.2/admin/

thanks, will sorry it's not so easy.


Community Member, 6 Posts

12 July 2009 at 4:46pm

might be worth noting, my issue is updating the DB to see new page type templates, is there any other way but build?flush to do this? Perhaps I can test what issue is if there's an alternate way.

Go to Top