Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

HTTP Error 500.21 - Internal Server Error - Handler "PHP_via_FastCGI" has a bad module "FastCGIModule" in its module list

Go to End

3 Posts   16503 Views


Community Member, 1 Post

21 July 2009 at 1:48am

I am confident this isn't a Silverstripe problem, but I end up with it when I am trying to install Silverstripe so I'm hoping someone else has run into (and solved) it as well.

PHP_via_FastCGI is the Handler that was automatically installed at some point as I didn't manually create it. But when I go in to edit it, FastCGIModule is, in fact, missing from the Module dropdown.

I am installing this on IIS7 on Vista SP2. I have CGI installed on the webserver (which is supposed to enable FastCGI as well). I installed PHP through the Web Platform Installer, then modified php.ini according to the instructions found here: I have installed the update to FastCGI as well through the WPI (when I download the file by itself I am told it's not for my system - perhaps because it detects SP2 and that update is already included?).

mySQL is also installed and running just fine.

SS install went smoothly.

I just get this when I try to access any PHP file through the web server. If I run "php -info" from the command line it displays the php settings just fine, so PHP itself seems to be working alright.

Can anyone assist with what is wrong with (apparently) my IIS config? It serves html files just fine, just not PHP files via FastCGI.


Community Member, 1 Post

16 February 2010 at 12:34pm

I had the same problem today... this is what I found.

Although the SP1 include the FastCGI already, it is not installed.
1.- I turned off the CGI support trought "Turn Windows Features on or off/Internet Information Services/World Wide Web Services/Application Development Features/CGI" and clicked ok then restarted my machine and turned it back on.

2.- Through IIS management console added a new Module mapping using "Handler Mappings" , I called it "PHP via fastCGI"
a) request path: *.php
b)Module: FastCgiModule
c)Executable: "C:\Program Files\PHP\php-cgi.exe" (do not forget the double quotes)
d) Name: PHP via FastCGI

and that worked for me, now I can do my php coding and play a little with wordpress.
I also did some chages within the php.ini file but latter on I did put back the old one and also worked fine.
Hope it helped you