Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Installation stops early and PHP 5 is required is in the Title

Go to End

6 Posts   3209 Views


Community Member, 3 Posts

28 July 2009 at 8:55am

I know this subject's been discussed a few times before, but it seems my case is a little different, hence the new discussion line...

I'm trying to install SS 2.3 on a public server. The first part goes fine (SS is not complaining about anything) and then when I start the installation, it stops after 4 lines (attached screenshot) and the page title reads "PHP 5 is required". After going through the posts here on the forum I tried the following:
- called phpinfo(); to check if php5 was running - it was
- I asked the server admin to change read/write rights to all files in the folder (especially .htaccess and the config file) so the server could modify them,
- I created 'temp', 'tmp' and 'silverstripe-cache' folders in the root folder and did the above to them
- I added

AddType x-mapp-php5 .php 
AddHandler x-mapp-php5 .php

to my .htaccess file, which ended with about 500 lines of strange-looking code being printed but still didn't help (screenshot 2).
- took backup of local working SS database and restored it on server

I'm wondering if my case is not similar to this one:
I finally got them to look at the .htaccess rewrite requirements for SilverStripe and they admitted that their system only allows simple .htaccess commands.

They basically can't support SilverStrip, joomla, wordpress or anything else that requires rewrites, so I'm guessing in my case that the install crashed out and incorrectly reported the PHP 5 required message.

Why? First of all, after putting the 'fresh' SS installation package in my root folder, going to my produced an empty/white page. To start the installer, I had to go to, which seems to me like some re-write problems perhaps.

I will check with my server admin if he can check the .htaccess file and perhaps the problem is there.

But still I would be grateful for any more tips and advice on how to get my SS up and running.

Best regards,


Attached Files

Community Member, 3 Posts

28 July 2009 at 11:47pm

Problem solved. It was indeed the server configuration that mattered in this case.

As it turns out, the SS installer requires the php_tokenizer module to be loaded, so if you encounter a similar problem, make sure this module is loaded.

best regards,



Community Member, 4 Posts

15 October 2009 at 9:17pm

And where did you get the php-tokenizer from? I have the same problem...


Community Member, 3 Posts

30 October 2009 at 9:33am

I have the same issue. I get as far as this ->

Installing SilverStripe...
I am now running through the installation steps (this should take about 30 seconds)

If you receive a fatal error, refresh this page to continue the installation

Creating 'mysite/_config.php'...
Creating /home/fhlinux134/g/
Creating '.htaccess' file...
Creating /home/fhlinux134/g/
Building database schema...
Checking that friendly URLs work...

then it hangs. I refreash, and I get the dreaded "500" error.

I have a feeling its an issue with friendly path names and the .htaccess file. I had a similar issue with Drupal.

The major problem is my domain provider WONT change anything on there servers configuration side (Apachie)

With drupal it was a simple hack after installation.

I'm hoping someone here can point me in the same direction, install hack maybe, as the .htaccess file is created on install

This CMS looks good... but if I dont get a solution, im going back to Joomla/Drupal.

Can anyone help?


Forum Moderator, 5523 Posts

30 October 2009 at 6:15pm

lord_lethris - did you try the fix to the .htaccess file that is listed at the top of the thread

AddType x-mapp-php5 .php 
AddHandler x-mapp-php5 .php

Adding that to the .htaccess file is usually enough to convince the server to love PHP5


Community Member, 3 Posts

31 October 2009 at 1:27am

I tried that my good man.

Now both IE and FF wants to download index.php rather than open the page.

I attach, what I can only describe as "As far as I get with the install"... this is also a split second AFTER its created the nuisance .htaccess file (I monitored the ftp site)

If I refresh this page, it will give me a "500 error"

Attached Files