Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Anyone on Leopard w/o MAMP?

Go to End

5 Posts   1908 Views


Community Member, 3 Posts

31 July 2009 at 5:46pm

Edited: 31/07/2009 5:50pm

I am reluctant to use MAMP because I went to the trouble of getting xdebug-2.0.5 to work with my PHP install (entropy's 5.3.0-3) so here's the deal:

1. Apache 2.2.11 (stock Leopard version)
-mod_rewrite IS DEFINITELY enabled
2. PHP 5.3.0-3
3. MySql 5.1.x
4. OSX 10.5.7

I get everything set up on SS's install page, but when I go ahead with the install, SS complains that either I need to enable mod_rewrite (it already is) or that I need to set AllowOverride All. When I set AllowOverride ANYWHERE (in httpd.conf, httpd-userdir.conf,*HOME*.conf) and try to return to the install page, I get a "forbidden" error. Has anyone set this up on OSX without MAMP?

BTW, if you're having trouble getting xdebug to work, I posted a solution:


Community Member, 12 Posts

3 August 2009 at 1:03pm

Yep, same problem for me.

It is necessary to add FollowSymLinks to the directory options in your apache configuration to allow mod_rewrite to work. So for me, using an alias I have the following:

Alias /mySilverstripeSite/ /Users/robinsouthgate/Workspaces/SilverStripeTest/

<Directory "/Users/robinsouthgate/Workspaces/SilverStripeTest/">
DirectoryIndex index.php
Options Indexes FollowSymLinks MultiViews
AllowOverride All
Order allow,deny
Allow from all

With that in place the installation goes through ok and I get no errors, but when it redirects me to my homepage I get a 404: The requested page couldn't be found. And then browsing to any pages that make use of sapphire (i.e. anything but the install.php) I get the same error.

This 404 is returned by ModelAsController.php if it can't find the correct page to return once it analyses the url segments. At this point it's clear the newly created rewrites are working so something else is broken and I'm stuck!


Community Member, 12 Posts

3 August 2009 at 3:22pm

My particular problems were because the database was corrupted probably from a previous failed install. Having added the symfollowlinks to options, I dropped the SS database and ran the install again and success!


Community Member, 1 Post

4 August 2009 at 9:37pm

I have set up my SS on OSX 10.5.7 with MAMP, and it worked out of the box... didn't even have to change any files...

maybe if you post your exact problem, i might be able to help...

Bruce B

Community Member, 164 Posts

5 August 2009 at 6:43pm

I also opted for the non-MAMP route. It was last year so the details are a bit fuzzy now but after compiling a version of PHP that included GD, I was able to get it all working.

And this by someone who normally will do anything to avoid typing the Terminal! So, it does work.

I've attached my notes made at the time.