Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

SilverStripe2.3.3 with IIS6 after installed can't load css and js


Go to End


4 Posts   2712 Views

Avatar
tsing

Community Member, 2 Posts

12 September 2009 at 12:39am

I have some problem with install SilverStripe ,can any one help me.
I install SilverStripe on a virtcal host with windows iis6 web server. After installed when i visited index.php all style lost. You can see http://tsing.sw01.zgvhost.net/index.php

When i get http://tsing.sw01.zgvhost.net/index.php/themes/blackcandy/css/layout.css?m=1231461288 it will redirected to http://tsing.sw01.zgvhost.net/index.php/themes/blackcandy/css/\/themes/blackcandy/css/layout.css

tsing

Thanks!

Avatar
WorkingSolution

Community Member, 18 Posts

12 September 2009 at 1:59am

Edited: 12/09/2009 2:10am

... blackcandy/css/ \ /themes/blackcandy/css/layout.css...

can't work.

have a look on your sourcecode - output:

  <link rel="stylesheet" type="text/css" href="http://tsing.sw01.zgvhost.net/index.php/themes/blackcandy/css/layout.css?m=1231461288">
  <link rel="stylesheet" type="text/css" href="http://tsing.sw01.zgvhost.net/index.php/themes/blackcandy/css/typography.css?m=1241404170">
  <link rel="stylesheet" type="text/css" href="http://tsing.sw01.zgvhost.net/index.php/themes/blackcandy/css/form.css?m=1223591384">

What does the "index.php" there?

You have deleted the install-files?

Call you Url so: http://tsing.sw01.zgvhost.net/
(without "index.php" and within "/" at end.

Look at your rewrite rules - there is something wrong. Maybe the wrong path.

Avatar
tsing

Community Member, 2 Posts

12 September 2009 at 5:46pm

Edited: 12/09/2009 5:47pm

Thank you WorkingSolution.

I have not deleted the index.php and install files. my default file is index.php so can access with http://tsing.sw01.zgvhost.net/ with not index.php in url.

I'm new to SilverStripe where I can change the rewrite ruls ? Because on IIS6 web server the .htaccess file don't work .

You can attempt to get url http://tsing.sw01.zgvhost.net/index.php/themes/blackcandy/css/layout.css?m=1231461288" on browser it will redirected incorrect url.

Avatar
WorkingSolution

Community Member, 18 Posts

12 September 2009 at 7:51pm

ahem...
when u use MS look here:
http://www.isapirewrite.com/

when it's ur own root server or u need to test on your local pc better use the windows - installer in the download section here
or use xampp: http://www.apachefriends.org/ - using xampp u have to edit the httpd.conf to set mode_rewrite to "on"

change

# LoadModule rewrite_module modules/mod_rewrite.so

to
LoadModule rewrite_module modules/mod_rewrite.so

then