Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Problem installing (mac OSX 10.6 with built-in PHP)


Go to End


7 Posts   3654 Views

Avatar
ccburns

Community Member, 79 Posts

16 September 2009 at 11:47pm

Hi Guys,

I am a newbie to SS, although I have quickly installed and played around with SS on a Linux server last month.

Now I am getting ready to seriously use it for a project so have decided to install it on my Mac 10.6. Unfortunately this time I am running into problems that I don't really know how to address.

The install starts (all of the install page config checks are green) fix the couple of access issues that the install suggests to fix. Then I click install and get a PHP date warning and then nothing. When I return to the root of the site it says - "The requested page couldn't be found."

I have included both the warning screen of the install and also the PHP information for the install.

I don't really know if my problem lies with the php config and the date setting specifically (but it says it is just a warning - not Fatal) or if the problem is something like mod_rewrite not being configured properly.

I am currently not using MAMP, although on my old machine I had the MAMP Pro licence so I can always install that if I absolutely have to. Although I would prefer not to if I can avoid it.

Any assistance or suggestion would be welcome.

Cheers,
Colin

Avatar
Bruce B

Community Member, 164 Posts

17 September 2009 at 2:09pm

I'm not sure if this is your problem - the PHP info file was a bit hard to read. If you are getting the warning about setting a timezone, this is because it seems that PHP under Snow leopard is set to issue Strict errors. The fix is to edit the file etc/php.ini. You may need to create this file from php.ini.default. The line you need to change is:
;date.timezone =

I changed mine to:
date.timezone = Australia/ACT
but you will probably want to use your own timezone setting. Google 'php timezone'
(note ; removed from the start of the line)

I haven't installed a new site under Snow Leopard but my existing sites transferred over after a few teething troubles (like this one).

Avatar
ccburns

Community Member, 79 Posts

17 September 2009 at 2:13pm

Thanks bruceb,

I had changed my php.ini etc, but the way PHP etc is set up under Mac OSX is a little confusing. I normally work on CentOS server. I have now installed MAMP and I am about it try installing SS. I will update the post later if this works smoothly.

Thanks for the email.

Cheers,
Colin

Avatar
ccburns

Community Member, 79 Posts

17 September 2009 at 2:32pm

Hi Guys,

I just wanted to update that I have now got this working correctly. I have installed MAMP and then had a few issues which I thought was mod_rewrite but it just turned out to be permissions of the folders. All installed and ready to start building ;)

I look forward to getting involved in the community. Hopefully I can find some ways to contribute.

Cheers,
Colin

Avatar
frodeaux

Community Member, 16 Posts

18 October 2009 at 9:46am

I'm having the identical problem. I really
want to use the system's apache and PHP
rather than re-installing MAMP which I've
used but would rather not.

Has anyone been able to run SilverStripe
under OS-X 10.6 with its Apache and PHP5.3?

Avatar
Bruce B

Community Member, 164 Posts

18 October 2009 at 11:10am

I have SS running happily under 10.6 using the standard Apache and PHP. Prior to Snow Leopard I was using a separate install of PHP because the previous OS X version didn't include GD.

The only 'gotchas' I had made notes on were the need to set the timezone in php.ini and a change to my.cnf to include the following line:
lower_case_table_names = 2
This was needed to to import MySQL files from other servers.

Let me know what problems you are having and I'll see if I can help.

Avatar
Bruce B

Community Member, 164 Posts

18 October 2009 at 11:28am

frodeaux, I just saw your other post. Is there anything in your error log that gives a clue? I don't recall seeing this problem, or if I did it must have been quickly fixed. if I remember, I'll let you know.