Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Stumped after previous successes with install

Go to End

25 Posts   7139 Views


Community Member, 45 Posts

19 October 2009 at 1:20am

That portion appears to be fine. I see that on my test installation too. - - [18/Oct/2009:23:14:47 +1100] [][rid#7fea732d3bd8/initial/redir#1] (3) [perdir /var/www/_silverstripe/] applying pattern '.*' to uri 'sapphire/main.php' - - [18/Oct/2009:23:14:47 +1100] [][rid#7fea732d3bd8/initial/redir#1] (4) [perdir /var/www/_silverstripe/] RewriteCond: input='/_silverstripe/sapphire/main.php' pattern='^(.*)$' => matched - - [18/Oct/2009:23:14:47 +1100] [][rid#7fea732d3bd8/initial/redir#1] (4) [perdir /var/www/_silverstripe/] RewriteCond: input='/var/www/_silverstripe/sapphire/main.php' pattern='!-f' => not-matched - - [18/Oct/2009:23:14:47 +1100] [][rid#7fea732d3bd8/initial/redir#1] (1) [perdir /var/www/_silverstripe/] pass through /var/www/_silverstripe/sapphire/main.php

Looking at that test, its checking to see if main.php is not a regular file, which correctly should return false.


Community Member, 45 Posts

19 October 2009 at 1:47am

The missing mysql libs as errors on apache startup are a worry. Do they show in a phpinfo() ?

Bed time for me, will check back tomorrow.



Community Member, 203 Posts

19 October 2009 at 2:45am

Edited: 19/10/2009 2:46am

They do not show up in phpinfo().

I posted a question about the missing modules on the entropy forums. Am wondering though in what way this could be entropy related - because I suspect that the three people here experiencing the problem have the same php module installed under osx. But I am not sure what to ask on that forum just yet.

Have a good night, working some more here in Berlin in cold autumn weather.


Community Member, 16 Posts

19 October 2009 at 6:00am

I've eliminated Apache2 + PHP5.3 as a possible source of the problem.
My current theory is that it's a configuration item in either httpd.conf
or php.ini.

I'm running Apache2 and PHP5.3 as provided by OS-X 10.6, as I
said in the original post. This morning I installed the XAMPP stack
as an experiment: it also has Apache2 and PHP5.3. Siliverstripe
installed and runs OK in that environment.

So the facts point to a problematic configuration of Apache or
PHP... not that that really narrows it down that much! I really want
to run under the standard OS-X versions so I'm still looking for
the culprit(s).


Community Member, 203 Posts

19 October 2009 at 6:25am

Edited: 19/10/2009 6:25am

Then it is probably something in apache, could indeed be the httpd.conf => I am not using the php 5.3 that came with my OS since it does not contain GD (and a quick google confirmed that 10.6 has that out of the box). I used Entropy instead.

But how about mysql, any of the more experienced Silverstripers here know if that could cause any of the problems we have? I am running 5.0.86.


Community Member, 16 Posts

19 October 2009 at 8:15am

The 404 message that appears for this failure, "The requested page couldn't be found." appears
only in ModelAsController.php inside the getNestedController method. I replaced the 404 HTTPResponse
with the throwing of an exception to get the following traceback at the point of failure:

[User Error] Uncaught UserException: Failed in getNested Controller
'/my/web/htdocs_silverstripe/sapphire/core/control/ModelAsController.php':85 __construct
'/my/web/htdocs_silverstripe/sapphire/core/control/ModelAsController.php':26 getNestedController
'/my/web/htdocs_silverstripe/sapphire/core/control/RootURLController.php':44 handleRequest
'/my/web/htdocs_silverstripe/sapphire/core/control/Director.php':281 handleRequest
'/my/web/htdocs_silverstripe/sapphire/core/control/Director.php':125 handleRequest
'/my/web/htdocs_silverstripe/sapphire/main.php':118 direct

The code here is not at all transparent and there are few comments to indicate what's
supposed to be happening. It be great if we could get one of the SilverStripe implementors
to take a look at this.


Community Member, 16 Posts

19 October 2009 at 11:03am

I can not explain how this helped, but after many hours of trying various
things to get the "success page" after an apparently successful install,
and always receiving the "The requested page couldn't be found." message,
I tried blowing away the SilverStripe MySql database before running the
install procedure again.

That worked.

I have no idea why why this fixed anything. If anyone can enlighten me
please do so. I hate unexplained "fixes".


Community Member, 203 Posts

19 October 2009 at 12:17pm

Edited: 19/10/2009 12:18pm

Well, I dropped all the tables, then went to my install and was redirected to and got the message "Setting up the database; you will be returned to your site shortly...." and a message telling me the date was not set correctly blablabla

Again got the requested page not found error, but I suspect this was caused by the fact that I tried accessing the silverstripe main page at instead of going to (I tested this: I dropped all the tables again and went back to to see what happened, and indeed, all the tables were back.)

Ok, now I get date errors in dataobject.php at line 912 instead of in the other file... Edited all the php.ini files I got in my system (the one that come with Entropy and the one that comes with the os) and so far no luck, Every time I get stuck at line 912 of the dataobject.php. If I can not get past this I switch to MAMP

Anyway, there is some progress, one little step at a time - am going to bed now, be back tomorow