Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Moved everything to webhost, only default pages showed up

Go to End

3 Posts   1399 Views


Community Member, 103 Posts

6 November 2009 at 6:13am

Hello all,

I just followed each step of these instructions:

Now when i visit my live site only the default Silverstripe pages (home, contact, about us) with default content are there. The theme is displaying correctly, and I did the export/import in phpmyadmin. No errors were mentioned in the process, just "110 queries were complete successfully". I did remember to click the "Add DROP TABLE / DROP VIEW" checkbox when exporting from phpmyadmin.

After importing the DB I tried:

My pages still do not show up. They are still working on my localcopy, so I'm sure that they are not missing from the DB. What table(s) are pages stored in. Perhaps they were not listed in the left hand column in phpmyadmin where you choose which tables you'd like to export for some reason? (I did select all of course when exporting).

Another thing I found odd is the number in parenthesis next to the database in my local version (i think this is # of tables?) is lower than on the live version. I expected them to match.

Thanks in advance!


Forum Moderator, 5523 Posts

6 November 2009 at 10:47am

Are you sure you imported the database into the correct one on your live host?.

What table(s) are pages stored in

Check the SiteTree table.


Community Member, 103 Posts

6 November 2009 at 11:08am

After looking a bit closer I just realized that going from windows (development) with lowercase table names to linux (web host) with uppercase table names is what was causing my problem. Changed to the proper case and the problem was solved.