Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We've moved the forum!

Please use forum.silverstripe.org for any new questions (announcement).
The forum archive will stick around, but will be read only.

You can also use our Slack channel or StackOverflow to ask for help.
Check out our community overview for more options to contribute.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Silverstripe 3.19 Rewrite problem


Go to End


5 Posts   2021 Views

Avatar
WebInt

Community Member, 14 Posts

24 January 2015 at 4:29am

After installation of 3.19 we get the message "Friendly URLs are not working. This is most likely because a rewrite module isn't configured correctly on your site. You may need to get your web host or server administrator to do this for you".

We already have numerous silverstripe websites on this server that are able to find mod_rewrite without any problem, so there is nothing wrong with mod_rewrite (which is built into apache anyway), or with the overrides. I assume the problem is with the new .htaccess file. Anyone any ideas?

Bob

Avatar
camfindlay

Forum Moderator, 267 Posts

26 January 2015 at 4:39pm

What version is your apache? I found Apache 2.4 you need to remove the index.php file to get things working.

Avatar
WebInt

Community Member, 14 Posts

6 February 2015 at 3:24am

Sorry Cameron, have been away. We are using Apache 2.2.15. on a webmin production install (centos 6).

We didn't find a way around this, and went back to version 3.18 with the security fix implemented. I still think there is a problem with the .htaccess, but it is obviously not a big deal if no-one else is reporting it. Thanks for your help.

Avatar
kinglozzer

Community Member, 187 Posts

6 February 2015 at 11:25pm

Does this bug report describe what you’re experiencing? https://github.com/silverstripe/silverstripe-framework/issues/3794

Avatar
WebInt

Community Member, 14 Posts

7 February 2015 at 12:49am

Yes, that's the one. Thanks very much for bringing it to my attention!