Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Releases and Announcements /

Latest news about the SilverStripe software.

Moderators: martimiz, Sean, Ed, biapar, assertchris, Willr, Ingo, swaiba, Graves

SilverStripe 2.3.1-rc1


Go to End


7 Posts   2897 Views

Avatar
Andante

Community Member, 231 Posts

12 March 2009 at 2:09pm

We have a new release of SilverStripe available: 2.3.1-rc1

We'd appreciate everyone's help testing it, so that we can make a stable release as soon as possible.

Download here: http://www.silverstripe.org/assets/rc/silverstripe-v2.3.1-rc1.tar.gz
Post bug reports here: http://open.silverstripe.org
Changelog here: http://open.silverstripe.org/wiki/ChangeLog/2.3.1

Thanks,
Andrew O'Neil

Avatar
clburkins

Community Member, 4 Posts

17 March 2009 at 2:11am

Hi, Is the plan for 2.3.1 to have the improvements to Translatable that are foreseen by this page? http://doc.silverstripe.com/doku.php?id=multilingualcontent?

Thanks.

Avatar
Taffy

Community Member, 119 Posts

17 March 2009 at 3:23am

Here is the ticket http://open.silverstripe.org/ticket/3517

The milestone is 2.3.2 rc1 which is due in 5weeks.

Avatar
clburkins

Community Member, 4 Posts

17 March 2009 at 5:05am

Thanks! That's exactly the information I needed.

Avatar
Fuzz10

Community Member, 791 Posts

18 March 2009 at 4:38am

Edited: 18/03/2009 4:42am

In Silverstripe 2.3.x ,

What happened to the static method get_by_url () ?

I'm using this in an application , but after upgrading to 2.3.1 , it stopped working

DataObject::get_by_url($URL)

ends up in a :

Call to undefined method DataObject::get_by_url()

Avatar
Ingo

Forum Moderator, 801 Posts

20 March 2009 at 10:56am

Its SiteTree::get_by_url() now - DataObjects don't have an URLSegment. Sorry for the confusion

Avatar
Fuzz10

Community Member, 791 Posts

20 March 2009 at 8:42pm

Hi Ingo,

Yup ... Thanks !