Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We've moved the forum!

Please use forum.silverstripe.org for any new questions (announcement).
The forum archive will stick around, but will be read only.

You can also use our Slack channel or StackOverflow to ask for help.
Check out our community overview for more options to contribute.

Showcase Questions /

Feedback and questions about sites in the Community Showcase.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

New forum look and feel (not dev friendly :( )


Go to End


10 Posts   6101 Views

Avatar
Bigweb.EU

Community Member, 8 Posts

20 September 2014 at 3:33am

Hi all,

I'm really disappointed in a new SS forum design - it bacame pretty much hard to read :(

1. Firstly - list of topics and colors of fonts - absolutely non readable !
if you try to go through from top to bottom - you'll see that most readable lines are user nicknames in red , which takes all of the attention .
Font color is fine for another Bootrap 4 pages site, but not enough contrast for a proper forum reading.
Suggestion - move date of creation with nickname to separate column, topics should be one under other, and probably use darker font.

2.Inside the topic - again, the max ammount of posts that fints the screen at a time (im on a full HD) - 2-3 posts. theres pleanty of room on the right side which is just wasted in white... Basically you can't track answers easily, and always have to skip author info and their images (which is NOT smth that is essential on forum).
Suggestion - again, keep author info in separate column, compact messages a bit, so that answers are one under another.

I understand you wanted the forum to look neat and accurate, but for developer important thing is getting required information fast . Old forum was way much better in a way of formatting. Any developer who sees this topic - please say your opinion, Im I right or not ? :) Or SS guys - just do a Poll and see results. :)

Cheers.

Avatar
clarkepaul

Community Member, 4 Posts

22 September 2014 at 2:19pm

Thanks for your input. I agree we can do better with the color contrast so I've added this as a bug.

With regards to some of the positioning of information, we are now having to deal with smaller form factors so we wanted to find layouts which are more consistent across devices without impacting the usability. With the old forum we were duplicating user details for each post so this was cleaned up a bit and we decided to simplify info into the one place. In the end it came down to simplicity of the structure but we did consider leaving user details on the right side and only appearing between posts for smaller screens. Moving the user details to the right should be an easy enough for just larger screens so I'll add this as a recommendation.

No need to do a poll atm as there are loads of improvements and feedback that didn't make the go live day which we hope to get to in the future.

Avatar
martimiz

Forum Moderator, 1391 Posts

23 September 2014 at 12:40am

Great new site setup, congratulations!! Obviously there will always be some small things to tweak :)

One such would be the admin options on the forums, that are placed very close together. On touch devices (iPad in my case), it's a bit of a gamble which link you'll hit, which might have unwanted sideeffects :)

Avatar
clarkepaul

Community Member, 4 Posts

26 September 2014 at 9:44am

Hi guys, we've made some quick changes as per some of the recommendations. There can be more improvements around color and contrast but we will do more of that over time.

Avatar
martimiz

Forum Moderator, 1391 Posts

26 September 2014 at 8:21pm

Edited: 26/09/2014 8:26pm

Thanks!

Where would you guys rather have us post bugs and recommendations concerning the new site? I don't really think this topic is the right place...

Anyhow one minor css thingy - text is running out of bounds here: this post

EDIT: Also noticed that links are no longer displayed as links - with or without formatting...

Avatar
jpalsu+

Community Member, 69 Posts

1 October 2014 at 9:55am

Edited: 01/10/2014 9:57am

Hi all,

I am also disappointed...

1/ There is no RSS, Neither for SilverStripe.org, nor SS.com, nor SS Forums...
Why ?

2/ For me, the new forum and blog are too slows, and less readable (for me)...

What was the real need to change ?

Bests regards
Friendly,

jpalsu
><((((°> <°))))><
Euskadi, I Love it !
Maite dut Euskal Herria
Le Pays Basque, J'aime

Avatar
clarkepaul

Community Member, 4 Posts

1 October 2014 at 4:19pm

Hi, there is currently a bug with RSS feeds which we are hoping to release a fix for tomorrow so bare with us. The ability to get notifications for a post shouldn't have changed from the old experience (you have the option to subscribe to threads once you respond) but the RSS feed has always been hidden from the interface (I don't know why that is - I hope to see if RSS needs to be visible on the front-end). As this launch was an initial basic upgrade of the site without additional features we hope to see more improvements in the near future.

The whole experience is not that different from the old experience but the visual appearance of the forum has changed. We gathered quite a lot of feedback from the community in regards to how the old site appeared and the consensus was that it didn't connect to the software or reflect the community it should represent (CMS authors, developers, web companies, designers, businesses using SilverStripe... ).

The two main reasons for change was that the old site was unmaintainable without doing a complete upgrade and that the user experience (navigating and the content) was bad and needed improving for a larger user base than just developers.

FYI - the feedback button at the bottom is the best place to give recommendations/feedback, and feel free to keep using the forum to gather opinions of others.

Cheers

Avatar
jpalsu+

Community Member, 69 Posts

1 October 2014 at 8:36pm

Edited: 03/10/2014 2:54am

ClarkePaul,
Thanks for your answer.
I understand the reasons for change.

But Rss is a great utility...
The old forums RSS feed was "http://www.silverstripe.org/community/forums/rss"
And now it doesn't work...

I don't see the "forward button" !
Where is it ?

Thanks for your help

Bests regards
Friendly,

jpalsu
><((((°> <°))))><
Euskadi, I Love it !
Maite dut Euskal Herria
Le Pays Basque, J'aime

Go to Top