Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Template Questions /

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Reinstalled SilverStripe, homepage template not working

Go to End

4 Posts   2282 Views


Community Member, 19 Posts

4 March 2011 at 2:44am

Hi All,

I was having some issues with a site and did a full reinstall of SilverStripe, then replacing the mysite folder with my original one, and adding my theme. All seems to be working OK except for the homepage, which shows up without any styling or without the content it should - it pulls content from other pages and news posts, etc. It's just showing up in plain text with it's heading and the text I've put in the editor to let the administrator know they can't actually add anything to the page manually. All other pages look fine so I have temporarily removed from the Layout folder and Homepage.php from the code folder to force a 404 error so the user can see the styling and access all other pages. I tried doing a dev/build?flush=all, no help.

What have I misssed/done wrong? How can I get my homepage to display correctly again?

Any suggestions ASAP will be most appreciated, more than you know ... I've been having issues with this site all night and it only went up three days ago (after spending six months on a subdomain as a demo with no problems ... very frustrated and stressed about it at the moment! I'll be indebted to anyone who can help me fix the problems we're having!)


Community Member, 15 Posts

24 March 2011 at 7:59am

did you resolve the issue? I have a similar problem at the moment - all my custom templates show up as plain text only on the server i just uploaded them to. In the dev. Environment everything was perfectly fine.


Community Member, 15 Posts

25 March 2011 at 1:30am

I'm working on this right now - trying to find out where i went wrong. This is what i have so far:

I already installed a similar website one the same server with 2 custom templates (home and news) and everything worked fine.

This time i installed another instance of silverstripe in a different directory for testing. I unpacked the tar.gz directly on the linux server for this one and did a clean install before uploading my data and importing the changed database.

After i realised, that my custom themes don't work in this environment i tried in _myconfig.php:
which i hadn't changed before

i also completely deleted everything in the cache folder and any temporary files i could find so far

but it still doesn't work.

But curiously, if i add a new page with one of my templates as page type it does work again.

On the other hand i think the scenario of changing the template for an existing page is quite common in my case so i hope to find out how to repair it.


Community Member, 15 Posts

25 March 2011 at 7:56am

ok - i found my error: i had a corrupt database, because i missed a few tables when renaming them for the transition between windows and linux.

(actually, looking at it now - my problem was probably a different one than the one the tread starter had)