Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Themes /

Discuss SilverStripe Themes.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

jquery.ui.tabs droste-efect error only in Silverstripe

Go to End

2 Posts   1647 Views


Community Member, 203 Posts

11 January 2012 at 9:28am

Edited: 17/01/2012 2:20am

This truly is a Silverstripe related question because the error only happens in in silverstripe, outside of silverstripe it works fine. I hope someone can explain me what is going wrong because I am at wits end here.

I have a html file that works perfectly with jquery, especially with jquery.ui.tabs and jquery.ui.accordion.

When I theme it, it works ok up until the moment I add the jquery.ui.tabs-part. What it does is: it creates a droste effect by adding the whole page inside the tabs (from metatags to footer). The result can be seen here EDIT: added a screenshot of the result, since I changed the page to work without ui.tabs

If I turn off javascript, copy the source silverstripe created and paste it in a new empty html file and render it in my browser it works fine - so it has nothing to do with my php code - but it has to do with Silverstripe.

What I tried:

  • - all requirements are cleared with Requirements::clear(); AND Validator::set_javascript_validation_handler('none');
  • - Turning off the different javascripts, plugins and what not revealed it only has to do with the jquery.ui.tabs-part
  • - I tried binding everything using requirements using the jquery parts that came with silverstripe and adding my script at the bottom. But the results are the same in silverstripe (tested it again in a test.html file and there it works fine).
  • - copying all the jquery files from sapphire/thirdparty to my theme dir - still no cigar.
  • - I am not logged in when I try it, I do not have $SilverStripeNavigator installed, have turned off everything in the _config.php in mysite to get rid of everything that has to do with testing. (see:
  • - And I tried it in three or four different browsers, tested it localy in MAMP and uploaded it to my server

As I said, I am at wits end here, I go experiment some more by rearranging my html code - then I have to head to bed and do some other job in the morning, so I might not reply timely.

And of course in the end it will be something very stupid and simple I did wrong so I am prepared:-)

EDIT: I am running 2.4.6 with the google sitemap plugin

Attached Files

Community Member, 203 Posts

14 January 2012 at 5:33am

The problem remains and as far as I can see it is more serious as I thought and it is really caused by Silverstripe - but do not know where it comes from. I used the demo file that comes with the jquery ui tabs downloads and simply renamed it - did not add any content, changed the links to the resources using $ThemeDir, added the <% base_tag %> and $MetaTags, added $Content and $Form so I could log in, and tested it with the 3.0 alpha2 version and a clean install of silverstripe 2.4.6. Same problem.

I attached a screenshot of what happens in the code and I attached the The Page.php is left as is from a clean install using SS 2.4.6 and 3.0 Alpha 2

I hope people understand this is not a rookie problem. I have build various websites with silverstripe and I am maybe not the top developer but I am building sites since over a decade (started in 1997 doing web things in 1997 for a web-magazine using bbedit and have worked as free lance web designer/coder since 2005)

And of course I hope someone can help me :-)

Attached Files