Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Themes /

Discuss SilverStripe Themes.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Themes other than Simple do not appear correctly

Go to End

10 Posts   3967 Views


Community Member, 3 Posts

15 November 2013 at 12:06pm

I've made a fresh install of SS 3.1.2 which ran without any problems until I came to edit a theme.

As in previous versions I took a copy of Simple theme and gave the folder a different name and uploaded to the server having changed the theme name in the composer.json file ...

The new theme appears in the "Settings" tab in the back end, BUT, if I change the theme to the copy of Simple the site loses all of the Black & White colouring of the Simple theme and shows a blue bar at the top with the page name and the site "content" underneath.

Clearly it's not picking up the newly selected theme but rather falling back to a much simpler theme.

I've tried all sorts trying to make this work - wiped the themes directory clean and re-uploaded, recopied the simple theme to another folder (With the same result), changed the theme name in _config.php and _config.yml.

Setting the site into "dev" mode doesn't show any errors.

I'm at a loss - can anyone help or is this a serious bug in the new release?

Many thanks - Jeremy


Community Member, 3 Posts

15 November 2013 at 1:00pm

Just to add to my previous post - I've tried repeating the exact same process with 3.0.8 and that works without a problem.

Looks a like a bug introduced into 3.1.2?


Community Member, 3 Posts

27 January 2014 at 3:00am

Hei, I am a newbie with silverstripe but I have exactly the same problem with using themes different from the "simple" theme in v.3.1.2.
It is impossible to use one of the themes published on the add-on pages. Is ther a solution for this problem?


Community Member, 1 Post

5 February 2014 at 7:55pm


I've also just started with SS 3.1.2, and getting the same issue. No themes seem to work, and there seems to be no answer from anyone. Does this mean SilverStripe is effectively a dead development with no further support?




Forum Moderator, 1391 Posts

6 February 2014 at 1:05am

Edited: 06/02/2014 1:07am

@jeremyge: no, SilverStripe is anything but dead! In fact there is a lot of development going on, thanks to the guys at SilverStripe and other great developers. Free SilverStripe support, though, is essentially a community effort... Most questions do get answered at some point, which should be obvious if you browse the threads :) I'm sorry yours seems to have slipped through initially.

As to the question at hand: this should be a caching issue. You should ?flush=all after installing/selecting a new theme - especially in 3.1! If that doesn't work for some reason, you might try emptying the cache. I usually create the (writable) silverstripe-cache directory in the site root for easy access.

Just in case: note that older templates might still not work correctly in v3 - take a look here:


Community Member, 3 Posts

6 February 2014 at 8:55am

@martimiz: I have found a lot of references in this forum that recommends to fush the cache but I have some questions on how exactly you do that flushing.
When I try this in my browser: "localhost/silverstripe/index.php?flush=all" (knowing that I launch my website with "localhost/silverstripe/index.php", I am rederected to a login page and after entering my id and password then the result is this IIS error: "HTTP-error 404.0 - Not Found" and the listed requested url with this error is: " http://localhost:80/silverstripe/silverstripe/index.php?flush=all&flushtoken=4fbf785f9081a1f145439a05d00de3de"
You also suggests to emty the cache folder manually but looking i my folder tree I can find more than one folder named "cache" and each of these folders contains one or more php-files. Which is the cache you are writing about: "framework/cache"? or "framework/thirdparty/zend/cache"? Do you mean with emptying deleting each file and sub-folders?
Silverstripe seems not to be so easy to use as it pretends.


Forum Moderator, 1391 Posts

7 February 2014 at 12:51am

Note that I'm not sure that flushing the cache will actually fix your issue, but anyway:

I'm referring to the silverstripe-cache folder in which SilverStripe caches its templates, classes and other related stuff. By default SilverStripe will place this folder in the tmp folder, but if you create a silverstripe-cache folder in the root of your website, SilverStripe will automatically use That - provided it's writable.

I always do it the latter way: it's more manageable and on a server/workstation that isn't setup correctly, using the tmp folder can even lead to errors. There are two situations:

Every time you add new database fields to your code, you need to do a localhost/silverstripe/dev/build?flush=1" - This will make SilverStripe update the database and appropriate files in the cache.

Everytime you change templates, themes or config values (including yml files or static variables like $allowed_actions, do a localhost/silverstripe/?flush=all

For this to work, you need to either be logged in as administrator to the CMS, or your site needs to be in dev mode. Best login first :)

In your case the error might have something to do with you having index.php in your url. This would indicate that mod-rewrite is not enabled on your server? Please check that your homepage is reachable as localhost/silverstripe/


Community Member, 3 Posts

7 February 2014 at 12:32pm

@martimiz: there is no mod_rewrite on IIS. I don't now why, but my site only launches correctly when I use the url localhost/silverstripe/index.php. Using localhost/silverstripe opens the site but with the message page not found. It has to do something with a segment named "home" that is added to my top-page in the admin screen.
Flushing seems to work (i do not receive an IIS anymorer) when I use the url you mentioned. The cache and tmp folder remains unfindable for me?? There is still only the simple template that is working
I don't think I'll manage to get silverstripe working as it should, I am afraid I will look for another CMS to evaluate.

Go to Top