Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Themes /

Discuss SilverStripe Themes.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Charity theme - No submenu?


Go to End


2 Posts   2166 Views

Avatar
boogieg

Community Member, 23 Posts

2 March 2009 at 6:32pm

Quick - hopefully simple - question:

I've installed Charity theme and it looks pretty good, but there doesn't seem to be a submenu for the subpages I've created.

Any chance anyone might be able to tell me which file I might need to edit - and what the necessary code changes might be? Would be a HUGE help to me. I'm bangin' my head against the wall over here.

thanks,
Gina

Avatar
Hamish

Community Member, 712 Posts

3 March 2009 at 5:38pm

Hmm, yeah it hasn't got them. I depends on where you want to display the submenu really.

You should edit \templates\Page.ss and put this line where you'd like the submenu:

<% include SubNavigation %>

Then create the file \templates\Includes\SubNavigation.ss

And make it look something like:

<% if Menu(2) %>
<ul>
 	<% control Menu(2) %>	  
  		<li><a href="$Link" title="Go to the $Title.XML page" class="$LinkingMode"><span>$MenuTitle</span></a></li>
   	<% end_control %>
</ul>
<% end_if %>

This should get you started :)