Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Themes /

Discuss SilverStripe Themes.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Problem with installing a new theme

Go to End

13 Posts   7427 Views


Community Member, 2 Posts

23 March 2010 at 12:08pm

Hi there,

Im new to cms all together, I have installed the 2.3.7 version and downloaded the paddygreen theme to have a play round with.

I have followed silverstripes instructions about going into the mysite/_config.php and changing SSViewer::set_theme('blackcandy'); to the following SSViewer::set_theme('paddygreen'); when i do this i get loads of issuse i use wamp at the moment and dont know if its me or if its that the paddygreen theme dont work on the 2.3.7 version [please look below and if you can help id appreciate it i can be contacted on

[Warning] None of these templates can be found:,
GET /silverstripe-v2.3.7/?stage=Stage

Line 175 in C:\wamp\www\silverstripe-v2.3.7\sapphire\core\SSViewer.php

166 $this->chosenTemplates['main'] = $this->chosenTemplates[$templateFolder];
167 unset($this->chosenTemplates[$templateFolder]);
168 }
169 }
171 if(isset($_GET['debug_request'])) Debug::message("Final template selections made: " . var_export($this->chosenTemplates, true));
173 }
175 if(!$this->chosenTemplates) user_error("None of these templates can be found: ". implode(".ss, ", $templateList) . ".ss", E_USER_WARNING);
177 parent::__construct();
178 }
180 /**
181 * Returns true if at least one of the listed templates exists


* None of these templates can be found:,
Line 175 of SSViewer.php
* SSViewer->__construct(Array)
Line 305 of Controller.php
* Controller->getViewer(index)
Line 172 of Controller.php
* Controller->handleAction(HTTPRequest)
Line 129 of RequestHandler.php
* RequestHandler->handleRequest(HTTPRequest)
Line 119 of Controller.php
* Controller->handleRequest(HTTPRequest)
Line 29 of ModelAsController.php
* ModelAsController->handleRequest(HTTPRequest)
Line 44 of RootURLController.php
* RootURLController->handleRequest(HTTPRequest)
Line 280 of Director.php
* Director::handleRequest(HTTPRequest,Session)
Line 121 of Director.php
* Director::direct(/)
Line 118 of main.php


James Carty


Forum Moderator, 5523 Posts

23 March 2010 at 1:11pm

Welcome James to the forums. Have you followed the instructions listed in this forum and trying to refresh the cache by visiting


Community Member, 2 Posts

24 March 2010 at 7:34am

Edited: 24/03/2010 7:35am

Hi willr

I tried that last night and it wouldnt worked but thought id try it again and for some reason it works now but hey never mind these things are here to try us lol.

Cheers ill look at some other stuff now on the website


Community Member, 12 Posts

22 May 2010 at 12:14am

Edited: 22/05/2010 12:16am

I have the same problem with the Blog-module. (blog 0.3.0)


276    public static function getTemplateContent($identifier) { 
277       return file_get_contents(SSViewer::getTemplateFile($identifier));

I was wondering what, in the theme, sets of this bug? I'm using a custom theme by another firm and wouldn't really like to patch core files since I'm an external.

Just wondering, they probably won't upgrade to 2.4 until mid-fall.


Forum Moderator, 5523 Posts

22 May 2010 at 10:42am

I think this issue is called by including a file that doesn't exist - go through your theme and remove as much as you can and it should work. By removing / putting back code in the ss files you should be able to track down what lines causing the issue.

Go to Top